<!DOCTYPE html><!--[if IE 6]> <html id="ie6" lang="en-US"> <![endif]--><!--[if IE 7]> <html id="ie7" lang="en-US"> <![endif]--><!--[if IE 8]> <html id="ie8" lang="en-US"> <![endif]--><!--[if !(IE 6) | !(IE 7) | !(IE 8)]><!--><html lang="en-US"><!--<![endif]--><head><meta charset="UTF-8"/>
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
if(typeof isOrig==='undefined'){isOrig=false;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){if((impId!=="0"||isOrig===true)&&adUnit!==""){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}}
function AddPixelById(impFullId,pixelData,isOrig,revenue){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];var pix={type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig};if(typeof revenue!=='undefined'){pix.revenue=revenue;}
pixels.push(pix);}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}});}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false;}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=195-1&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=195-1&cb=4', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=195-1&cb=5', false, [], true, false, true, false);</script>
	
	<link rel="pingback" href="https://www.bigblueinteractive.com/xmlrpc.php"/>

	<!--[if lt IE 9]>
	<script src="https://www.bigblueinteractive.com/wp-content/themes/suffusion/scripts/html5.js" type="text/javascript"></script>
	<![endif]-->
<meta name="robots" content="index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1"/>
<link rel="dns-prefetch" href="https://static.hupso.com/share/js/counters.js"/><link rel="preconnect" href="https://static.hupso.com/share/js/counters.js"/><link rel="preload" href="https://static.hupso.com/share/js/counters.js"/><meta property="og:image" content="https://www.bigblueinteractive.com/wp-content/uploads/Evan-Neal-Alabama-Crimson-Tide-December-31-2021-233x300.jpg"/>
	<!-- This site is optimized with the Yoast SEO plugin v18.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>New York Giants 2022 NFL Draft Preview: Offensive Tackles</title>
	<meta name="description" content="BigBlueInteractive&#39;s 2022 NFL draft preview focusing on offensive tackles from the perspective of the New York Giants."/>
	<link rel="canonical" href="https://www.bigblueinteractive.com/2022/04/18/new-york-giants-2022-nfl-draft-preview-offensive-tackles/" />
	<meta property="og:locale" content="en_US"/>
	<meta property="og:type" content="article"/>
	<meta property="og:title" content="New York Giants 2022 NFL Draft Preview: Offensive Tackles"/>
	<meta property="og:description" content="BigBlueInteractive&#39;s 2022 NFL draft preview focusing on offensive tackles from the perspective of the New York Giants."/>
	<meta property="og:url" content="http://www.bigblueinteractive.com/2022/04/18/new-york-giants-2022-nfl-draft-preview-offensive-tackles/"/>
	<meta property="og:site_name" content="Big Blue Interactive"/>
	<meta property="article:published_time" content="2022-04-18T12:50:01+00:00"/>
	<meta property="og:image" content="http://www.bigblueinteractive.com/wp-content/uploads/Evan-Neal-Alabama-Crimson-Tide-December-31-2021.jpg"/>
	<meta property="og:image:width" content="497"/>
	<meta property="og:image:height" content="640"/>
	<meta property="og:image:type" content="image/jpeg"/>
	<meta name="twitter:card" content="summary"/>
	<meta name="twitter:label1" content="Written by"/>
	<meta name="twitter:data1" content="David Syvertsen"/>
	<meta name="twitter:label2" content="Est. reading time"/>
	<meta name="twitter:data2" content="1 minute"/>
	<script type="application/ld+json" class="yoast-schema-graph">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</script>
	<!-- / Yoast SEO plugin. -->


<link rel="dns-prefetch" href="//fonts.googleapis.com"/>
<link rel="dns-prefetch" href="//s.w.org"/>
<link rel="alternate" type="application/rss+xml" title="Big Blue Interactive » Feed" href="https://www.bigblueinteractive.com/feed/"/>
<link rel="alternate" type="application/rss+xml" title="Big Blue Interactive » Comments Feed" href="https://www.bigblueinteractive.com/comments/feed/"/>
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.bigblueinteractive.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.5"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel="stylesheet" id="wp-block-library-css" href="https://www.bigblueinteractive.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7.5" type="text/css" media="all"/>
<link rel="stylesheet" id="hupso_css-css" href="https://www.bigblueinteractive.com/wp-content/plugins/hupso-share-buttons-for-twitter-facebook-google/style.css?ver=5.7.5" type="text/css" media="all"/>
<link rel="stylesheet" id="social-widget-css" href="https://www.bigblueinteractive.com/wp-content/plugins/social-media-widget/social_widget.css?ver=5.7.5" type="text/css" media="all"/>
<link rel="stylesheet" id="suffusion-google-fonts-css" href="https://fonts.googleapis.com/css?family=Droid+Sans:400,700" type="text/css" media="all" />
<link rel="stylesheet" id="suffusion-theme-css" href="https://www.bigblueinteractive.com/wp-content/themes/suffusion/style.css?ver=4.4.9" type="text/css" media="all"/>
<link rel="stylesheet" id="suffusion-theme-skin-1-css" href="https://www.bigblueinteractive.com/wp-content/themes/suffusion/skins/light-theme-gray-1/skin.css?ver=4.4.9" type="text/css" media="all"/>
<link rel="stylesheet" id="suffusion-child-css" href="https://www.bigblueinteractive.com/wp-content/themes/bbitheme/style.css?ver=4.4.9" type="text/css" media="all"/>
<!--[if !IE]>--><link rel="stylesheet" id="suffusion-rounded-css" href="https://www.bigblueinteractive.com/wp-content/themes/suffusion/rounded-corners.css?ver=4.4.9" type="text/css" media="all"/>
<!--<![endif]-->
<!--[if gt IE 8]><link rel='stylesheet' id='suffusion-rounded-css'  href='https://www.bigblueinteractive.com/wp-content/themes/suffusion/rounded-corners.css?ver=4.4.9' type='text/css' media='all' />
<![endif]-->
<!--[if lt IE 8]><link rel='stylesheet' id='suffusion-ie-css'  href='https://www.bigblueinteractive.com/wp-content/themes/suffusion/ie-fix.css?ver=4.4.9' type='text/css' media='all' />
<![endif]-->
<link rel="stylesheet" id="tablepress-default-css" href="https://www.bigblueinteractive.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.14" type="text/css" media="all"/>
<link rel="stylesheet" id="wp-cpl-base-css-css" href="https://www.bigblueinteractive.com/wp-content/plugins/wp-category-posts-list/static/css/wp-cat-list-theme.css?ver=2.0.3" type="text/css" media="all"/>
<link rel="stylesheet" id="wp_cpl_css_0-css" href="https://www.bigblueinteractive.com/wp-content/plugins/wp-category-posts-list/static/css/wp-cat-list-light.css?ver=2.0.3" type="text/css" media="all"/>
<link rel="stylesheet" id="wp_cpl_css_1-css" href="https://www.bigblueinteractive.com/wp-content/plugins/wp-category-posts-list/static/css/wp-cat-list-dark.css?ver=2.0.3" type="text/css" media="all"/>
<link rel="stylesheet" id="wp_cpl_css_2-css" href="https://www.bigblueinteractive.com/wp-content/plugins/wp-category-posts-list/static/css/wp-cat-list-giant-gold-fish.css?ver=2.0.3" type="text/css" media="all"/>
<link rel="stylesheet" id="wp_cpl_css_3-css" href="https://www.bigblueinteractive.com/wp-content/plugins/wp-category-posts-list/static/css/wp-cat-list-adrift-in-dreams.css?ver=2.0.3" type="text/css" media="all"/>
<script type="text/javascript" src="https://www.bigblueinteractive.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1" id="jquery-core-js"></script>
<script type="text/javascript" src="https://www.bigblueinteractive.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2" id="jquery-migrate-js"></script>
<script type="text/javascript" src="https://www.bigblueinteractive.com/wp-content/plugins/menu-in-post/js/main-min.js?ver=5.7.5" id="menu_in_post_frontend_script-js"></script>
<script type="text/javascript" src="https://www.bigblueinteractive.com/wp-content/themes/suffusion/scripts/jquery.cycle.all.min.js" id="suffusion-jquery-cycle-js"></script>
<script type="text/javascript" id="suffusion-js-extra">
/* <![CDATA[ */
var Suffusion_JS = {"wrapper_width_type_page_template_1l_sidebar_php":"fixed","wrapper_max_width_page_template_1l_sidebar_php":"1200","wrapper_min_width_page_template_1l_sidebar_php":"600","wrapper_orig_width_page_template_1l_sidebar_php":"75","wrapper_width_type_page_template_1r_sidebar_php":"fixed","wrapper_max_width_page_template_1r_sidebar_php":"1200","wrapper_min_width_page_template_1r_sidebar_php":"600","wrapper_orig_width_page_template_1r_sidebar_php":"75","wrapper_width_type_page_template_1l1r_sidebar_php":"fixed","wrapper_max_width_page_template_1l1r_sidebar_php":"1200","wrapper_min_width_page_template_1l1r_sidebar_php":"600","wrapper_orig_width_page_template_1l1r_sidebar_php":"75","wrapper_width_type_page_template_2l_sidebars_php":"fixed","wrapper_max_width_page_template_2l_sidebars_php":"1200","wrapper_min_width_page_template_2l_sidebars_php":"600","wrapper_orig_width_page_template_2l_sidebars_php":"75","wrapper_width_type_page_template_2r_sidebars_php":"fixed","wrapper_max_width_page_template_2r_sidebars_php":"1200","wrapper_min_width_page_template_2r_sidebars_php":"600","wrapper_orig_width_page_template_2r_sidebars_php":"75","wrapper_width_type":"fixed","wrapper_max_width":"1200","wrapper_min_width":"600","wrapper_orig_width":"75","wrapper_width_type_page_template_no_sidebars_php":"fixed","wrapper_max_width_page_template_no_sidebars_php":"1200","wrapper_min_width_page_template_no_sidebars_php":"600","wrapper_orig_width_page_template_no_sidebars_php":"75","suf_featured_interval":"6000","suf_featured_transition_speed":"1000","suf_featured_fx":"fade","suf_featured_pause":"Pause","suf_featured_resume":"Resume","suf_featured_sync":"0","suf_featured_pager_style":"numbers","suf_nav_delay":"500","suf_nav_effect":"fade","suf_navt_delay":"500","suf_navt_effect":"fade","suf_jq_masonry_enabled":"disabled","suf_fix_aspect_ratio":"preserve","suf_show_drop_caps":""};
/* ]]> */
</script>
<script type="text/javascript" src="https://www.bigblueinteractive.com/wp-content/themes/suffusion/scripts/suffusion.js?ver=4.4.9" id="suffusion-js"></script>
<link rel="https://api.w.org/" href="https://www.bigblueinteractive.com/wp-json/"/><link rel="alternate" type="application/json" href="https://www.bigblueinteractive.com/wp-json/wp/v2/posts/109903"/><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.bigblueinteractive.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.bigblueinteractive.com/wp-includes/wlwmanifest.xml"/> 
<link rel="shortlink" href="https://www.bigblueinteractive.com/?p=109903"/>
<link rel="alternate" type="application/json+oembed" href="https://www.bigblueinteractive.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bigblueinteractive.com%2F2022%2F04%2F18%2Fnew-york-giants-2022-nfl-draft-preview-offensive-tackles%2F"/>
<link rel="alternate" type="text/xml+oembed" href="https://www.bigblueinteractive.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.bigblueinteractive.com%2F2022%2F04%2F18%2Fnew-york-giants-2022-nfl-draft-preview-offensive-tackles%2F&amp;format=xml"/>
<!-- Graceful Pull-Quotes plugin v2.6.1 -->
	<link rel="stylesheet" href="https://www.bigblueinteractive.com/wp-content/plugins/graceful-pull-quotes/resources/jspullquotes-core.css" type="text/css" />
	<link rel="stylesheet" href="https://www.bigblueinteractive.com/wp-content/plugins/graceful-pull-quotes/resources/jspullquotes-default.css" type="text/css" />
	<script type="text/javascript">
		var jspq_options = new Array("1", "1", "right", "1", "1", "blockquote", "pullquote", "pullquote pqRight");
	</script>
	<script type="text/javascript" src="https://www.bigblueinteractive.com/wp-content/plugins/graceful-pull-quotes/resources/jspullquotes.js"></script>
<!-- end pull-quote additions -->
                       <style type="text/css">
              @media screen {
                    .printfriendly {
                       position: relative;
                        z-index: 1000;
                     margin: 
                        12px 12px 12px 12px                     ;
                  }
                  .printfriendly a, .printfriendly a:link, .printfriendly a:visited, .printfriendly a:hover, .printfriendly a:active {
                       font-weight: 600;
                      cursor: pointer;
                       text-decoration: none;
                     border: none;
                      -webkit-box-shadow: none;
                      -moz-box-shadow: none;
                     box-shadow: none;
                      outline:none;
                        font-size: 14px !important;
                        color: #6D9F00 !important;
                   }
                  .printfriendly.pf-alignleft {
                      float: left
                    }
                  .printfriendly.pf-alignright {
                     float: right;
                  }
                  .printfriendly.pf-aligncenter {
                        display: flex;
                     align-items: center;
                       justify-content: center;
                   }
              }
          }

         @media print {
             .printfriendly {
                   display: none;
             }
          }

         .pf-button-img {
               border: none;
              -webkit-box-shadow: none; 
             -moz-box-shadow: none; 
                box-shadow: none; 
             padding: 0; 
               margin: 0;
             display: inline; 
              vertical-align: middle;
            }
          
           img.pf-button-img + .pf-button-text {
              margin-left: 6px;
          }
        </style>

        <style type="text/css" id="pf-excerpt-styles">
          .pf-button.pf-button-excerpt {
              display: none;
           }
        </style>
                <!-- Start Additional Feeds -->
<!-- End Additional Feeds -->
	<!-- CSS styles constructed using option definitions -->
	<style type="text/css">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</style>
		<!-- Custom CSS styles defined in options -->
		<style type="text/css">
			/* <![CDATA[ */
#widgets-above-header .suf-widget{background:#444444;border:none;}
#cred { background:#ffffff;}
aside#text-3{background:#000078;}
div#sidebar {background:#000078;border:none;margin-top:0px;}
#header { padding: 0px; }
div.suf-mag-excerpts-header{font-size:20px;color:#444444;}
h2.suf-mag-headlines-title{font-size:20px;color:#444444;}
div.suf-mag-categories-header{font-size:20px;color:#444444;}
div.suf-mag-excerpt-image{width:200px;float:left;background:#FFFFFF;}
div#sidebar-2 li {list-style:none;margin:0;background:none;}
#nav ul.sf-menu {margin-bottom:1px;}
#nav ul.sf-menu a.with-arrow{padding-left:16px;}

aside#text-226374681 {padding:0;margin:0;text-align:center;}
aside#text-226374681 div.textwidget{padding:0;margin:0;text-align:center;}
.down-ptr {background:none;width:2px;}
div#eazyest-gallery-1{margin-bottom:50px;}

#nav.continuous{position: relative; z-index: 99999; }

h1.blogtitle, h2.blogtitle{
padding: 0px;
margin: 0px;
width: 650px;  
overflow:none;  
}

#header-widgets div.widget_text{
 border:none;
  width:260px;
 padding-left:10px;
 text-align:right; 
  
}

@media (max-width: 649px) {

h1.header {
width: 100%;
height: auto;
}

h2.header {
width: 100%;
height: auto;
}

.blogtitle img {
width: 100%;
height: auto;
}
}

@media  ( max-width :  480px ) {

section.suf-mag-headlines{display:none;}

}			/* ]]> */
		</style>
		<!-- /Custom CSS styles defined in options -->
<!-- location header -->
<!-- Begin comScore Tag -->

<script>

  var _comscore = _comscore || [];

  _comscore.push({ c1: "2", c2: "6035223" });

  (function() {

    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;

    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";

    el.parentNode.insertBefore(s, el);

  })();

</script>

<noscript>

  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" />

</noscript>

<!-- End comScore Tag --><script type="text/javascript">
(function() {
var useSSL = 'https:' == document.location.protocol;
var src = (useSSL ? 'https:' : 'http:') +
'//www.googletagservices.com/tag/js/gpt_mobile.js';
document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
})();
</script>
<script type="text/javascript">
googletag.cmd.push(function() {
googletag.enableServices();
googletag.pubads().setTargeting("page_url", "URL");
});
</script><!-- Begin YES header tag -->
<script type="text/javascript">
var section = "Big Blue Interactive";
var ctxPath = "";
var pageid = "index";
var dc_keyVal = "";
</script>

<!-- End YES header tag --><!-- Start DFP SETUP - Header Tags -->
<script type="text/javascript">
      var gptadslots=[], googletag = googletag || {}; googletag.cmd = googletag.cmd || [];
      (function(){ var gads = document.createElement('script');
          gads.async = true; gads.type = 'text/javascript';
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
      })();
</script>
<script type="text/javascript" src="https://img.bnqt.com/lib/js/sdpdfphelper.js"></script>
<script type="text/javascript">
      googletag.cmd.push(function() {
          googletag.pubads().enableAsyncRendering(); googletag.pubads().enableSingleRequest();
          googletag.pubads().setTargeting('title', sdpTargeting.title)
                            .setTargeting('targetPaths', sdpTargeting.targetPaths)
                            .setTargeting('fullPath', sdpTargeting.fullPath)
                            .setTargeting('queryStr', sdpTargeting.queryStr)
                            .setTargeting('domainName', sdpTargeting.domainName);
      });
</script>
<!-- DFP SETUP end --><script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-38817621-1', 'bigblueinteractive.com');
  ga('send', 'pageview');

</script><script language="JavaScript" type="text/JavaScript">
function changePage(newLoc)
 {
   nextPage = newLoc.options[newLoc.selectedIndex].value
		
   if (nextPage != "")
   {
      document.location.href = nextPage
   }
 }
</script>



<script type="text/javascript">var ezouid = "1";</script><base href="https://www.bigblueinteractive.com/2022/04/18/new-york-giants-2022-nfl-draft-preview-offensive-tackles/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 124135;
var ezdomain = 'bigblueinteractive.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":124135,"domain_test_group":20210306,"engaged_time_visit":0,"ezcache_level":2,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"6f3ba087-fe2e-4d26-4f6c-72b533eb13ab","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":145042,"response_time_orig":15,"serverid":"54.198.154.114:14236","state":"VA","t_epoch":1650321319,"template_id":126,"time_on_site_visit":0,"url":"https://www.bigblueinteractive.com/2022/04/18/new-york-giants-2022-nfl-draft-preview-offensive-tackles/","user_id":0,"word_count":6841,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_124135=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["6f3ba087-fe2e-4d26-4f6c-72b533eb13ab", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>

<body class="post-template-default single single-post postid-109903 single-format-standard light-theme-gray-1 suffusion-custom preset-custom-componentspx device-desktop">

    			<!-- #widgets-above-header -->
	<div id="widgets-above-header" class="warea fix">
		<div class="col-control">
<!-- widget start --><div id="custom_html-3" class="widget_text widget_custom_html suf-widget suf-widget-1c"><div class="textwidget custom-html-widget"><!-- SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.main -->
<div id="usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.main">
     <script type="text/javascript">
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103,22280986322/SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.main', [728,90], 'usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.main').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.main');
         });
     </script>
</div>
</div></div><!-- widget end -->		</div>
	</div>
	<!-- /#widgets-above-header -->
		<div id="wrapper" class="fix">
					<div id="header-container" class="custom-header fix">
					<header id="header" class="fix">
			<h2 class="blogtitle left"><a href="https://www.bigblueinteractive.com"><img src="http://bigblueinteractive.com/images/header-image-700.gif" alt="Big Blue Interactive"/></a></h2>
		<div class="description hidden">The Latest News, Analysis and Discussion of the New York Football Giants</div>
    </header><!-- /header -->
	<!-- #header-widgets -->
	<div id="header-widgets" class="warea">
<!-- widget start --><div id="text-533808691" class="widget_text suf-widget suf-widget-1c">			<div class="textwidget"> </div>
		</div><!-- widget end -->	</div>
	<!-- /#header-widgets -->
 	<nav id="nav" class="continuous fix">
		<div class="col-control left">
<ul class="sf-menu">
<li id="menu-item-33111" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-33111 dd-tab"><a href="https://www.bigblueinteractive.com">Home</a>
<ul class="sub-menu">
	<li id="menu-item-33113" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33113"><a href="https://www.bigblueinteractive.com/information-pages/terms-of-use/">Terms Of Use</a></li>
	<li id="menu-item-33114" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33114"><a href="https://www.bigblueinteractive.com/information-pages/code-of-conduct/">Code Of Conduct</a></li>
	<li id="menu-item-33115" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33115"><a href="https://www.bigblueinteractive.com/information-pages/privacy-policy/">Privacy Policy</a></li>
	<li id="menu-item-33116" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33116"><a href="https://www.bigblueinteractive.com/information-pages/frequently-asked-questions-faq/">FAQ</a></li>
	<li id="menu-item-33117" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33117"><a href="https://www.bigblueinteractive.com/information-pages/about-us/">About Us</a></li>
	<li id="menu-item-72147" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72147"><a href="https://www.bigblueinteractive.com/information-pages/contact-us/">Contact Us</a></li>
</ul>
</li>
<li id="menu-item-33112" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-33112 dd-tab"><a href="http://corner.bigblueinteractive.com/index.php">Corner Forum</a>
<ul class="sub-menu">
	<li id="menu-item-33119" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33119"><a href="http://corner.bigblueinteractive.com/index.php?show=1">All Threads</a></li>
	<li id="menu-item-33120" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33120"><a href="http://corner.bigblueinteractive.com/index.php?show=2">Football Threads</a></li>
	<li id="menu-item-33121" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33121"><a href="http://corner.bigblueinteractive.com/index.php?show=3">Non-Football Threads</a></li>
	<li id="menu-item-33122" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33122"><a href="http://corner.bigblueinteractive.com/index.php?show=5">Forum Archives</a></li>
</ul>
</li>
<li id="menu-item-35092" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-35092 dd-tab"><a href="#">Gameday</a>
<ul class="sub-menu">
	<li id="menu-item-35093" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35093"><a href="https://www.bigblueinteractive.com/new-york-giants-schedule/">Schedule</a></li>
	<li id="menu-item-35094" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35094"><a href="https://www.bigblueinteractive.com/new-york-giants-game-previews-reviews/">BBI Game Previews and Reviews</a></li>
	<li id="menu-item-35096" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35096"><a target="_blank" rel="noopener" href="http://www.nfl.com/standings">Standings (NFL.com)</a></li>
	<li id="menu-item-35097" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35097"><a target="_blank" rel="noopener" href="https://www.giants.com/team/stats/">Statistics (Giants.com)</a></li>
	<li id="menu-item-35095" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35095"><a href="https://www.bigblueinteractive.com/new-york-giants-historical-statistics/">Historical Statistics</a></li>
</ul>
</li>
<li id="menu-item-33118" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-33118 dd-tab"><a href="https://www.bigblueinteractive.com">Team</a>
<ul class="sub-menu">
	<li id="menu-item-33123" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33123"><a href="https://www.bigblueinteractive.com/information-pages/new-york-giants-roster/">Roster</a></li>
	<li id="menu-item-33124" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33124"><a href="https://www.bigblueinteractive.com/information-pages/new-york-giants-depth-chart/">Depth Chart</a></li>
	<li id="menu-item-33125" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33125"><a href="https://www.bigblueinteractive.com/information-pages/new-york-giants-scouting-reports/">Scouting Reports</a></li>
	<li id="menu-item-33126" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33126"><a href="https://www.bigblueinteractive.com/information-pages/new-york-giants-transactions/">Transactions</a></li>
	<li id="menu-item-33127" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33127"><a href="https://www.bigblueinteractive.com/information-pages/new-york-giants-player-salaries/">Player Salaries</a></li>
</ul>
</li>
<li id="menu-item-35103" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-35103 dd-tab"><a href="#">Team Building</a>
<ul class="sub-menu">
	<li id="menu-item-35104" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35104"><a href="https://www.bigblueinteractive.com/free-agency/">Free Agency</a></li>
	<li id="menu-item-35105" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35105"><a href="https://www.bigblueinteractive.com/new-york-giants-nfl-draft/">NFL Draft</a></li>
	<li id="menu-item-35106" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35106"><a href="https://www.bigblueinteractive.com/new-york-giants-training-camp/">Training Camp</a></li>
</ul>
</li>
<li id="menu-item-33128" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-33128 dd-tab"><a href="https://www.bigblueinteractive.com/information-pages/annual-records-and-team-accolades/">Giants Info &amp; History</a>
<ul class="sub-menu">
	<li id="menu-item-33130" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33130"><a href="https://www.bigblueinteractive.com/information-pages/new-york-giants-contact-information/">Contact Info</a></li>
	<li id="menu-item-33131" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33131"><a href="https://www.bigblueinteractive.com/information-pages/new-york-giants-team-administration/">Administration</a></li>
	<li id="menu-item-33132" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33132"><a href="https://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-staff/">Coaching Staff</a></li>
	<li id="menu-item-33133" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33133"><a href="https://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-history/">Coaching History</a></li>
	<li id="menu-item-33134" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33134"><a href="https://www.bigblueinteractive.com/information-pages/new-york-giants-annual-records/">Annual Records</a></li>
	<li id="menu-item-33135" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33135"><a href="https://www.bigblueinteractive.com/information-pages/hall-of-fame-new-york-giants/">Hall Of Fame</a></li>
	<li id="menu-item-33136" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33136"><a href="https://www.bigblueinteractive.com/information-pages/new-york-giants-retired-jersey-numbers/">Retired Jerseys</a></li>
	<li id="menu-item-33137" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33137"><a href="https://www.bigblueinteractive.com/information-pages/new-york-giants-ring-of-honor/">Ring Of Honor</a></li>
</ul>
</li>
<li id="menu-item-35102" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-35102 dd-tab"><a href="#">Info/Links</a>
<ul class="sub-menu">
	<li id="menu-item-35107" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35107"><a href="https://www.bigblueinteractive.com/new-york-giants-important-dates/">Important Dates</a></li>
	<li id="menu-item-48512" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48512"><a href="https://www.bigblueinteractive.com/information-pages/bigblueinteractivecom-player-of-the-year-award-winners/">Giant of the Year Award</a></li>
	<li id="menu-item-35108" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35108"><a href="https://www.bigblueinteractive.com/new-york-giants-articles/">Articles</a></li>
	<li id="menu-item-35109" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35109"><a href="https://www.bigblueinteractive.com/glossary/">Glossary</a></li>
	<li id="menu-item-35110" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35110"><a href="https://www.bigblueinteractive.com/links/">Links</a></li>
</ul>
</li>


</ul>
		</div><!-- /col-control -->
	</nav><!-- /nav -->
			</div><!-- //#header-container -->
		

<!-- Sept 2021  Launchpad goes below here -->


<!-- SMG_BigBlueInteractive/launchpad/sports/football/nfl.main -->
<div id="usmg_ad_SMG_BigBlueInteractive_launchpad_sports_football_nfl.main">
     <script type="text/javascript">
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103,22280986322/SMG_BigBlueInteractive/launchpad/sports/football/nfl.main', [[970,66],[970,250]], 'usmg_ad_SMG_BigBlueInteractive_launchpad_sports_football_nfl.main').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_launchpad_sports_football_nfl.main');
         });
     </script>
</div>



	
			<div id="container" class="fix">
				    <div id="main-col">
		  	<div id="content">
<!-- SiteCatalyst code version: G.5. Copyright 1997-2003 Omniture, Inc. More info available at http://www.omniture.com -->
<div style="position:absolute; top:-100px; left:-100px; width:100px;">
<script type="text/javascript" src="/MLBAM_tracking.js"></script>
</div>
<!-- End SiteCatalyst code version: G.5. -->	<article class="post-109903 post type-post status-publish format-standard has-post-thumbnail hentry category-articles category-the-draft tag-2022-nfl-draft category-8-id category-82-id full-content meta-position-corners fix" id="post-109903">


<!-- SMG_BigBlueInteractive/outstream/sports/football/nfl.general -->


<script>!function(e,t,a,n,g){e[n]=e[n]||[],e[n].push({"gtm.start":(new Date).getTime(),event:"gtm.js"});var m=t.getElementsByTagName(a)[0],r=t.createElement(a);r.async=!0,r.src="https://www.googletagmanager.com/gtm.js?id=GTM-PL4PD49",m.parentNode.insertBefore(r,m)}(window.parent,window.parent.document,"script","dataLayer");</script><script>var iframe=window.parent.document.createElement("iframe");iframe.src="https://www.googletagmanager.com/ns.html?id=GTM-PL4PD49";iframe.height="0";iframe.width="0";iframe.style="display:none;visibility:hidden";window.parent.document.body.appendChild(iframe);</script><script>window.parent['$$mm-analytics'] = window.parent['$$mm-analytics'] || {};if (typeof window.parent['$$mm-analytics'].firstEmbed === 'undefined') {window.parent['$$mm-analytics'].firstEmbed = Date.now();}</script><script async="" type="text/javascript" src="https://bucket1.mm-syringe.com/prod/configs/0ed7b503-aa2d-46c4-85ad-88669fa21b92.js"></script><script async="" type="text/javascript" src="https://bucket1.mm-syringe.com/prod/injector/injector.1.5.3.js"></script>


<header class="post-header title-container fix">
	<div class="title">
		<h1 class="posttitle"><a href="https://www.bigblueinteractive.com/2022/04/18/new-york-giants-2022-nfl-draft-preview-offensive-tackles/" class="entry-title" rel="bookmark" title="New York Giants 2022 NFL Draft Preview: Offensive Tackles">New York Giants 2022 NFL Draft Preview: Offensive Tackles</a></h1>
		<div class="postdata fix">
		<span class="author"><span class="icon"> </span>Posted by <span class="vcard"><a href="https://www.bigblueinteractive.com/author/david-syvertsen/" class="url fn" rel="author">David Syvertsen</a></span></span>	</div><!-- /.postdata -->
		</div><!-- /.title -->
		<div class="date"><span class="month">Apr</span> <span class="day">18</span><span class="year">2022</span></div>
	</header><!-- /.title-container -->
	<span class="post-format-icon"> </span><span class="updated" title="2022-04-18T08:50:01-04:00"></span>		<div class="entry-container fix">
			<div class="entry fix">
<!-- Start USAT June 2018 Code  -->

<div class="ctcg_68715" style="width:1px;height:1px"></div>
<script>(function(doc){

                                var gec = function(c){return doc.getElementsByClassName ? doc.getElementsByClassName(c) : doc.querySelectorAll("."+c);}

                                var tpc = "[ENTER_CLICK_URL_UNESCAPED]",

                                                tpi = "[ENTER_IMPRESSION_URL_UNESCAPED]",

                                                ch = "",

                                                p = location.protocol === "https:" ? "https:" : "http:", s = doc.createElement("script"),

                                                idx = gec("ct_invocation_68715").length,c = gec("ctcg_68715");

                                s.className="ct_invocation_68715 ct_invocation_68715_"+idx;

                                if (c&&c[0]) c[0].className = "ctcg_68715_" + idx;

                                s.setAttribute("tpc",tpc);s.setAttribute("tpi",tpi);s.setAttribute("ch", ch);

                                s.src = p+"//invocation.combotag.com/placement_invocation?id=68715&idx="+idx;

                                doc.getElementsByTagName("head")[0].appendChild(s);

                })(document);

</script>


<!-- End USAT June 2018 Code  --><div class="pf-content"><div style="padding-bottom:20px; padding-top:10px;" class="hupso-share-buttons"><!-- Hupso Share Buttons - https://www.hupso.com/share/ --><a class="hupso_counters" href="https://www.hupso.com/share/"><img src="https://static.hupso.com/share/buttons/share-small.png" style="border:0px; padding-top:2px; float:left;" alt="Share Button"/></a><script type="text/javascript">var hupso_services_c=new Array("twitter","facebook_like","facebook_send","google","pinterest");var hupso_counters_lang = "en_US";var hupso_image_folder_url = "";var hupso_twitter_via="bigblueinteract";var hupso_url_c="";var hupso_title_c="New%20York%20Giants%202022%20NFL%20Draft%20Preview%3A%20Offensive%20Tackles";</script><script type="text/javascript" src="https://static.hupso.com/share/js/counters.js"></script><!-- Hupso Share Buttons --></div><div id="attachment_109905" style="width: 507px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-109905" loading="lazy" src="https://www.bigblueinteractive.com/wp-content/uploads/Evan-Neal-Alabama-Crimson-Tide-December-31-2021.jpg" alt="Evan Neal, Alabama Crimson Tide (December 31, 2021)" class="size-full wp-image-109905" width="497" height="640" srcset="https://www.bigblueinteractive.com/wp-content/uploads/Evan-Neal-Alabama-Crimson-Tide-December-31-2021.jpg 497w, https://www.bigblueinteractive.com/wp-content/uploads/Evan-Neal-Alabama-Crimson-Tide-December-31-2021-233x300.jpg 233w, https://www.bigblueinteractive.com/wp-content/uploads/Evan-Neal-Alabama-Crimson-Tide-December-31-2021-116x150.jpg 116w" sizes="(max-width: 497px) 100vw, 497px" /><p id="caption-attachment-109905" class="wp-caption-text">Evan Neal – © USA TODAY Sports</p></div>
<p class="p1"><strong>OFFENSIVE TACKLES</strong></p>
<p class="p1"><em><span class="italics">90+: All Pro Projection</span></em></p>
<p>85+: Pro Bowl Projection</p>
<p>81-84: 1st rounder – Should be able to play right away</p>
<p>79-80: 2nd rounder – Should be able to rotate right away – Year 2 starter</p>
<p>77-78: 3rd rounder – Should be able to rotate by end of rookie year – Year 2/3 starter</p>
<p>74-76: Early Day 3 – Special Teams – Future backup/possible starter</p>
<p>71-73: Mid Day 3 – Special Teams – Future backup / gamble starter</p>
<p>68-70: Late Day 3 – Back end of roster / Practice Squad / Development guy</p>
<p>65-67: Preferred UDFA</p>
<p>60-64: Undrafted FA</p>
<p><span class="bold"><strong>1: Evan Neal – Alabama – 6’7/337</strong></span></p>
<p><strong>Grade: 87</strong></p>
<p>Summary: Junior entry from Okeechobee, Florida. Three-year starter at three different positions (LG, RT, LT). A 2019 Freshman All American that ended his career as a 2nd Team All American and 1st Team All SEC honoree. Neal, a team captain, is lauded by both the on-field coaches and support staff inside the walls. His attention to detail, intelligence, and work ethic have helped him deliver on his 5-star recruit profile out of high school. The fact he started right away as a true freshman for Nick Saban along the offensive line, a rarity, and progressed each season of his 3-year career while playing 3 different positions speaks volumes about his mental game. The obvious with Neal is the elite physical tools. His size is second to none, his power comes easy and natural, and the explosion within his blocking can put him in a rare tier of offensive line prospects. He did struggle with consistency throughout his career, as he showed low body awareness in several situations. He often oversets, leading to balance and control issues. Defenders were able to shake him off too many times. Neal’s upside is as high as it gets but the constant new-position he dealt with every year may have thrown off some important development. That versatility may help his outlook to some teams but once he is drafted, his true value will come when he settles into a position. Neal can eventually be one of the best linemen in the game.</p>
<p>*Prior to the start of the year, I had nearly no-doubt Neal was going to finish in the 90+ tier. But this is where you have to toss pre-conceived notions out the window when watching the tape. The truth is, Neal did not take a step forward. There are shortcomings within his skill set that arose weekly. The positive? These are all very correctable issues, and we see them corrected all the time. He has some of the same issues that Tristan Wirfs did coming out of Iowa in 2020. Wirfs was my OT1 in that class with a similar grade and is now an All-Pro. Neal can get on that path just as quickly, but I think he needs to settle into a position and remain there for a couple years. That hasn’t been the case since he was a high schooler. NYG would be an ideal destination for him. Insert him into the RT spot week 1 and they could have a top tier OT pair within a year or two. I would be excited to get this kid in blue.</p>
<p><span class="bold"><strong>2: Ikem Ekwonu – NC State – 6’4/310</strong></span></p>
<p><strong>Grade: 87</strong></p>
<p>Summary: Junior entry from Charlotte, North Carolina. Three-year starter that has seen time at both left guard and left tackle. Two-time 1st Team All ACC and 2021 1st Team All American. The former wrestler was the also the anchor on his high school track team at 280+ pounds. Ekwonu will immediately be one of the best athletes along the offensive line in the league. His explosion, twitch from head to toe, and comfort in space as a lead blocker will be a viable weapon on an NFL offense early on. He is constantly putting defenders on the ground, as he can turn that speed into power at the snap of a finger. The issue with Ekwonu, however, is what we see out of homerun hitters in baseball. In between the highlights are far too many strikeouts. His lack of space-awareness and angles cause too many losses. His footwork is off, and his hands are often too late, which NFL defenders will eat for breakfast. The upside is through the roof, and he does carry credible inside-out versatility, but there is a lot of work to be done. He could start inside at guard in the NFL and will be most valuable in the running game when he can get out in space.</p>
<p>*For the record, Ekwonu graded out in the same tier at guard as tackle. It would be a hard call to pick between the two spots where he should start his career off. If the long-term plan is to put him at tackle, you might as well put him there right away. But if a team has 2 capable tackles and a hole at guard, I would not hesitate to put him inside. He has that kind of power, and he will make a bigger initial impact there. Ekwonu has holes in his game, just like Neal. Those issues, also like Neal, are very correctable. And lastly, like Neal, that is what kept him out of the 90+ tier. The upside is on that level at both guard and tackle. I do see a scenario where he is the guy I want NYG to go after at #5. It is pretty specific in terms of what happens 1-4, but it is possible. He would be a fun player to watch, and I would like the fit next to Glowinski for his mental progression. A part of me would wonder, however, if it would be a better idea to insert him at left guard and try to fill in RT next year. What a left side that would be.</p>
<p><span class="bold"><strong>3: Charles Cross – Mississippi State – 6’5/307</strong></span></p>
<p><strong>Grade: 85</strong></p>
<p>Summary: Third year sophomore entry from Laurel, Mississippi. Two-year starter that earned 1st Team All SEC honors in 2021. Cross has all the tools and on-field intelligence to be a starting tackle in the league. His size and athletic ability look natural and easy. He has a calmness about him in pass protection that is hard to find. Rarely does he seem off balance or out of control even when he needs to adjust his weight and intentions at the final moment. There are some brute strength and power issues that show up in the running game, but if he continues on the track we have seen with his body development over the last three years, he should bridge the gap in that department soon enough to potentially be considered one of the top tackles in the league. He can already do things against speed, quickness, and scheme-complexity that many pros cannot. His upside us as high as any offensive lineman in the draft.</p>
<p>*If you are looking for a tackle solely for pass protection, a strong case can be made for Cross being the top dog. His body control is what stands out the most to me. When you watch the top pass blocking tackles in the league, you rarely see their numbers facing the ground. You rarely see them overextending or bending from the hip. This is what I see in Cross every time I watch him play. He does have losses on tape which stem from a weak initial punch and lack of grip strength. That needs to be enhanced, no question. Hand fighting is an essential part of blocking and while I think he has the skill set down, he just needs to get stronger. The build is there, and he has done a nice job adding some weight since being recruited. I do think he is in play for #7 if NYG goes elsewhere at #5.</p>
<p><span class="bold"><strong>4: Trevor Penning – Northern Iowa – 6’7/325</strong></span></p>
<p><strong>Grade: 83</strong></p>
<p>Summary: Fifth year senior from Clear Lake, IA. Three-year starter that did not play in 2020 because the program cancelled the season. He played in both a shortened spring and full fall season respectively in 2021. Capped off his career with first team All-MVFC and All-American honors in addition to being named a finalist for the Walter Payton Award, given to the Offensive Player of the Year in FCS. Penning brings immense size, power, and attitude to the trenches. He is the kind of player that gets slid into a starting offensive line and all the sudden the personality up front is changed. To say he plays nasty and physical would be an understatement. Penning does have a few athletic shortcomings, as he doesn’t have the ever-present agility and bend below the waist. However, the capabilities are there to be just good enough at minimum and his overall power and mass should be able to hide most of the issues. There is a possibility his best fit would be inside, but he should get a shot to man a starting tackle spot early in his career.</p>
<p>*Penning was barely recruited out of high school. He spent just a year-plus on the offensive line. And he played at the lowest level of Iowa high school football. Now? He is a 325-pound freak that some can rightfully argue brings the best blend of talent to the table of all linemen in this class. I have a feeling we are going to see Penning go a lot earlier than where some are projecting him. He is a dream come true for some offensive line coaches. Still relatively raw when it comes to playing offensive line, elite burst and power, a pro-ready body, a love for the weight room, and a tenacity that can change the personality of an entire offense. Penning is a bit of a gamble because even from a lower level of college football, he was out-quicked far too often for my liking. But after seeing him workout, a case can be made he just doesn’t fully know what he is doing yet. And if/when he does, he can be a Pro Bowl talent.</p>
<p><span class="bold"><strong>5: Abraham Lucas – Washington State – 6’6/315</strong></span></p>
<p><strong>Grade: 79</strong></p>
<p>Summary: Fifth year senior from Everett, WA. Four-year starter that earned All-Pac 12 honors all four seasons, first team in both 2020 and 2021. Lucas is a highly experienced and accomplished right tackle that checks all the boxes when it comes to the tools and physical skill set. He is a superb pass blocker that does a lot of the little things right on a repeated basis. His footwork and body control, both in space and while engaged with the defender, are consistent. He is not the best natural athlete, and it does show up on occasion, but he rarely abandons his techniques and there is a presence of denseness to him. He plays strong and heavy when things are lined up. His issues, which center around consistent bend and hand-timing, are very correctable. Lucas will be a starting right tackle in the league by his second year and should have a long career in the league.</p>
<p>*Lucas may need a little more time than most guys with a 79 grade. He did not play in anything close to a pro-blocking scheme and was rarely ever asked to run block. There is a level of weakness to his game as well. He is like a JV version of Charles Cross. Really smooth and reliable pass blocker but does not get enough push yet in the running game. His frame is there, though, and he does have some attitude to him that showed up at the Senior Bowl. I liked him there. If NYG does not get an OT early, he is on my short list overall for day 2.</p>
<p><span class="bold"><strong>6: Tyler Smith – Tulsa – 6’5/324</strong></span></p>
<p><strong>Grade: 79</strong></p>
<p>Third year sophomore entry from Forth Worth, TX. Two-year full-time starter that also started two games in his redshirt season. Earned All-AAC honors in both 2020 and 2021. Smith is an explosive bruiser that plays the game with some extra attitude and violence. He plays with the kind of untamed mean streak that, when lined up properly, can be a true difference maker for an offensive line. His size and foot speed give him a high ceiling, but it will take some time to get there. He got away with poor techniques across the board in college that will not fly in the NFL. He needs to completely refine his hand work, get more comfortable with knee bend, and improve his body overall. Smith may need to make a move inside but even there, his ability to anchor will need time to build up. Look for him to be steady contributor within two years with a high upside.</p>
<p>*Look for Smith as another candidate for NYG to move inside if they can get their hands on him day 2. He plays the game like a violent guard. The lack of consistency in his bend and hand placement will cause issues on the outside early on. Inside, however, there is more margin for error in that department because he wouldn’t be as responsible for as much space. That said, most teams will see a potential tackle here that likely needs to sit a year. He has a high enough upside to warrant round 2.</p>
<p><span class="bold"><strong>7: Nicholas Petit-Frere – Ohio State – 6’5/316</strong></span></p>
<p><strong>Grade: 79</strong></p>
<p>Summary: Fourth year junior entry from Tampa, Florida. Two-year starter that transitioned to left tackle in 2021, finishing as a 2nd Team All American and earned 1st Team All Big 10 honors. Petit-Frere was an elite, top-rated high school recruit at the tackle position coming out. It took him a little extra time before he was ready to contribute on the field, but he put forth two solid seasons at both right and left tackle respectively. The body, athletic ability, and overall upside are enough to forecast a starting job in his future, however it may not be right away. There are a lot of inconsistencies in his game that need to be hammered out before can be fully trusted. He carries tightness in his lower half that translates into poor initial movement, delayed reactions, and a lack of sustainable power. When he does have all his techniques lined up, he has shown flashes of being a dominant player. The plays in between those positive stretches are what can cause some worry and delay his impact on a quality offense. Boom or bust type that would be best suited as a backup early on.</p>
<p>*There are stretches of play where Petit-Frere looks like a definite first rounder. He looks the part both pre and post snap. He has starting experience on both sides of the ball. He put a lot of quality work into the offseasons throughout his career. My glaring negative when breaking down his grade is the fact that his performances against arguably his two toughest opponents were poor. Hutchinson from Michigan and Ebikitie from Penn State, two pro-caliber edge guys, nearly destroyed him. I’ve said this before, but I will repeat it. How these guys respond to those matchups will always mean a lot to my final grades. Petit-Frere was a first rounder in my eyes until those game tapes. He has the ability, but it needs to come together on a more reliable basis.</p>
<p><span class="bold"><strong>8: Bernhard Raimann – Central Michigan – 6’6/307</strong></span></p>
<p><strong>Grade: 77</strong></p>
<p>Senior from Steinbrunn, Austria. Two-year starter at left tackle after starting 11 games over the previous two seasons at tight end. Earned first team All-MAC honors in 2021. Raimann played tight end until 2020 and it took just 18 games at his new position to become a credible pro prospect. His quick feet and overall twitch carry over well. He can stay under control against speed but also shows advanced knowledge and understanding of hand-techniques. He usually gets them inside while staying square and the ability to constantly stop and re-direct complements that well. Raimann is still rough around the edges and does not have the prototype-frame for the position. He lacks ample reach and struggles to keep his outside shoulder strong in pass protection, and it could cause a move inside. However, his skill set and lack of push off the ball could hinder his ability at guard. The athleticism and rawness do leave the door open for more obtainable upside than most prospects at the position, but there is a lot of development needed, which will take extra time.</p>
<p>*Raimann will turn 25 early in the 2022 season. He has a lot of big-time supporters around the league. It sounds like he will be a 2nd rounder. My initial read on him was 3rd or 4th round and after seeing the entire package, I did cement him into day two. That said, I don’t see a way to move him higher than where I have. There are too many unprovens when it comes to his skill set. Now, if he fixes the outside shoulder issues and gets a little more consistent with his lower body overall, and the actual ability is there I’ll admit, then we are looking at a starter. But the lack of length, lack of consistency, and core-based issues are too much for me to consider him any higher.</p>
<p><span class="bold"><strong>9: Rasheed Walker – Penn State – 6’6/313</strong></span></p>
<p><strong>Grade: 76</strong></p>
<p>Summary: Fourth year junior from Waldorf, Maryland. Three-year starter that earned third team All-Big 10 honors in 2020. Walker has all the tools and traits to be a quality starting tackle in the NFL. His size and athleticism are hard to find together in one player. When his techniques are lined up, they come together and create quality blocking. He has the suddenness and explosive hands to re-direct defenders while keeping the lower half active and fast. His issues revolve around inconsistent spacing between his feet. It causes him to lose balance and power, notably in pass protection when he needs to move to his outside shoulder. In time, Walker can be a high-end player but he will need quality coaching, patience, and an unwavering work ethic.</p>
<p>*Walker is getting over a minor knee injury that prevented him from working out at both his pro day and the scouting combine. There are also some maturity question marks with him that will cause teams to hesitate in a deep group day three linemen. With that said, Walker’s best tape rivals several of the guys in the day two group. He has the goods. The lack of consistency and questions noted above will likely cause NYG to steer clear, however.</p>
<p><span class="bold"><strong>10: Luke Goedeke – Central Michigan – 6’5/312</strong></span></p>
<p><strong>Grade: 75</strong></p>
<p>Summary: Senior entry from Whitelaw, WI. Two-year starter that missed all of 2020 after a knee injury that required surgery. First team All-MAC in 2021. Goedeke played right tackle all but one snap over his career. He shows dominant traits in the running game that stem from a combination of mentality and hand strength. He locks on with active feet and uses all his mass to get movement off the line. He plays with solid top to bottom cohesion and understands the angle-battle well. His size and lack pure athletic ability may force a move inside, but he should at least get a look at tackle. He is a fighter, one that relishes the role of being a security guard. Goedeke can be the important sixth lineman that can man different spots when injuries arise with the upside of being a starter down the road.</p>
<p>*After a career at tackle, he may have to make a shift inside due to length concerns. Goedeke is also a solid, but not great, mover in pass protection. He is one of the handful of guys you could project to either spot but I kept him out here because he never played inside at Central Michigan. Goedeke is not far off from Raimann, who gets much more attention it seems. Watch the two snap to snap (easy to do since they are on the same film) and you’ll see they trade back and forth positive/negative plays. I see Goedeke as the career backup type that you don’t want to head into the season as your starter, but OK with him coming in when an injury pops up.</p>
<p><span class="bold"><strong>11: Kellen Diesch – Arizona State – 6’7/301</strong></span></p>
<p><strong>Grade: 75</strong></p>
<p>Fifth year senior from Trophy Club, TX. Two-year starter for Arizona State after transferring from Texas A&amp; M where he spent three seasons as a backup. Earned second team All-Pac 12 honors in 2021. Diesch is a natural, easy-looking pass protector on the edge with smooth and repeatable footwork. His techniques are near-flawless, and it led to an incredibly high success rate on an island against pass rushers. He falls well below the prototype size for the tackle position, however, and may not have the anchor-strength for inside right away. There is a lot of weight room work to be done here but there is no denying how good he is at blocking, simply put. Diesch knows how to get the job done and could project as a valuable backup that could overcome a size deficiency in time and evolve into a quality starter.</p>
<p>*Diesch is a guy that falls below the size requirements on multiple levels but has such quality tape that you get reminded how much of an art this is. There are teams that will not even look at Diesch. But then there are teams that will look at the movement in pass protection, the easy and calm hands, and the ability to stay square will want to roll the dice. Diesch was one of my favorite guys to watch tape early in the year (and in 2020). But you must be careful knowing that the lack of anchor and length can, quite easily, be eaten alive by quality pass rushers. I would want this kid on my depth chart for a year or two to see if something can be made of him.</p>
<p><span class="bold"><strong>12: Max Mitchell – Louisiana – 6’6/307</strong></span></p>
<p><strong>Grade: 75</strong></p>
<p>Summary: Senior entry from Monroe, LA. Three-year starter that earned All-Sun Belt honors in both 2020 and 2021, first team in his final season. A well-balanced technician, Mitchell brings a very nice base-level skill set to work with. He has a natural and ever-present sense of body control and balance that can set him up well in pass protection. The sudden hand work and mobile hips will get him a lot of initial wins up the edge. He is not big or strong enough yet. He will need a redshirt for his initial pro season with a personal key to the weight room. If he can gain quality weight while maintaining his developed skill set, Mitchell has starter-capability at either tackle spot. A move to guard could be in the works as well, but the lower body mass and anchor need to vastly improve.</p>
<p>*Mitchell has one of the key traits I want in a lineman, more specifically at tackle. He maintains excellent body control and balance while he is engaged with his man. Even though he does not have the plus-speed or size, he stays in phase and rarely gets caught oversetting or losing his anchor. Simply put, he showed he knows how to block. I liken him to a poor man’s version of Dillon Radunz from last year, a 2nd rounder for TEN that had to sit most of the year while he beefed up. I see Mitchell being a similar guy, just a hair lower when it comes to talent and upside. Always have room for this guy on a depth chart.</p>
<p><span class="bold"><strong>14: Vederian Lowe – Illinois – 6’5/314</strong></span></p>
<p><strong>Grade: 73</strong></p>
<p>Summary: Fifth year senior from Rockford, IL. Started all five years because of receiving extra eligibility because of Covid-19. Honorable Mention All-Big 10 in both 2020 and 2021. Lowe, a father of two, is highly lauded by coaches and teammates. He also plays with a sense of maturity on the field. The techniques are repeated snap after snap, and it translates to superb body control and reliability. The feet and hands are in complete cohesion with one another, and it is rare to see him abandoning his base. Lowe does not bring a high end of speed or power to the table, but he is a blocker that simply gets the job done. His body type is unique. Lowe does not project to a top-tier status, but he will outplay and outlast players drafted ahead of him. He has things put together so well and his skill set will continue to improve in time.</p>
<p>*Lowe reminds me of a slightly lesser version, also slightly bigger version of Isaiah Wynn. The way he moves, the way he absorbs contact, and the ever-present sense of control. This is a dark horse guy worth trying to remember. I do have some concerns with him against top tier NFL speed and quickness, but if I can get him in round 5, I would be pumped. I think NYG will like the dependable traits he has. Highly respected by coaches, was impressive in interviews at the combine, has 2 kids, and set the Illinois record for starts (52).</p>
<p><span class="bold"><strong>14: Daniel Faalele – Minnesota – 6’8/384</strong></span></p>
<p><strong>Grade: 73</strong></p>
<p>Senior entry from Melbourne, Australia. Three-year started that opted out in 2020 because of Covid-19. Faalele is going to stand out because of his rare size for obvious reasons. He will immediately be one of the largest humans in the league full of giants. What makes him even more intriguing, however, is the fact he started playing football for the first time in 2016 with his first game action occurring a year later. Faalele moves off the ball exceptionally well for a player of his size. The baseline athletic ability is good enough but where he struggles is when unplanned adjustment and lateral shifts of weight are needed. That, along with the likelihood of eventual injury playing at such a heavy weight, is why he will need to shed a few pounds before being depended on. He can win a lot of battles because of his mass and natural power, but the speed and complexity of the NFL will expose movement issues too often if he stays on his current path. He has upside and potential as a power blocker that others simply do not, but there is a lot that needs to be lined up prior to getting there.</p>
<p>*I can see where kid can come across as a unicorn. You just don’t see 400 pounders that can move their feet the way he does. But for my money, I’ll let someone else take the chance. I don’t trust the long term of health of someone that weighs this much and to be frank, there are some defenders he may not even be able to get his hands on. In a league where the low, bendy, fast pass rushers are becoming more and more prevalent, Faalele may simply be coming into the league at the wrong time.</p>
<p><span class="bold"><strong>15: Austin Deculus – LSU – 6’5/321</strong></span></p>
<p><strong>Grade: 71</strong></p>
<p>Summary: Fifth year senior from Mamou, LA. Four-year starter that saw all his snaps at right tackle. Deculus has been a mainstay on an offensive line that has been one of the best performing groups in the nation over the past three years. He does not have standout talent or a dominating skill set, but it is hard to find a lot of bad beats on tape. He is just big enough and just powerful enough to hide the significant agility issues. He has heavy feet and stiff ankles, however his upper body strength and overall mass is hard to cleanly get by. There is a strong athletic base here, thus the notion there is some untapped potential lives on. Deculus has work to do, but there is a lot of pro-readiness to his game already. He can be a multiple year project that could end up being a quality starter in the league.</p>
<p>*Another guy well known for his durability (school record 61 games). Deculus is a better athlete than what we see on tape. He is a prime candidate for a draft and stash scenario (although I’m not sure how safe he is on the practice squad) for a year or two. Have him hammer away work at his agility and lower body mobility and see what he can develop into. Deculus has the man-power already and, most importantly, he knows how to win against better athletes. He can recover, an often overlook component to a quality lineman.</p>
<p><span class="bold"><strong>BEST OF THE REST</strong></span></p>
<p><strong>16: Braxton Jones – Southern Utah – 6’5/310: 71</strong><br/>
<strong>17: Zachary Thomas – San Diego State – 6’5/308: 71</strong><br/>
<strong>18: Myron Cunningham – Arkansas – 6’5/320: 70</strong><br/>
<strong>19: Obinna Eze – TCU – 6’6/321: 70</strong><br/>
<strong>20: Cade Mays – Tennessee – 6’5/311: 69</strong><br/>
<strong>21: Dare Rosenthal – Kentucky – 6’7/29: 69</strong><br/>
<strong>22: Matt Waletzko – North Dakota – 6’8/312: 69</strong><br/>
<strong>23: Alec Anderson – UCLA – 6’5/304: 69</strong><br/>
<strong>24: Andrew Rupcich – Culver-Stockton – 6’6/318: 68</strong><br/>
<strong>25: Caleb Jones – Indiana – 6’9/370: 68</strong><br/>
<strong>26: Luke Tenuta – Virginia Tech – 6’8/319: 68</strong><br/>
<strong>27: Tyler Vrabel – Boston College – 6’6/315: 68</strong><br/>
<strong>28: Bamidele Olaseni – Utah – 6’7/339: 68</strong><br/>
<strong>29: Greg Long – Purdue – 6’3/304: 67</strong><br/>
<strong>30: Devin Cochran – Georgia Tech – 6’7/306: 67</strong></p>
<p><strong>NYG APPROACH</strong></p>
<p>If I were a betting man, I would put a lot of money on NYG using #5 or #7 on one of the top four tackles. I say four because there is some love for Trevor Penning around the league that nobody is talking about, although I think the decision comes down to the obvious Ekwonu, Neal, or Cross trio. Let’s break this down, as I would put them all at equal odds to be the guy NYG goes for.</p>
<p>Ekwonu is the best athlete of the bunch and probably offers the most upside when it comes to handling speed and quickness. While his technique as a pass blocker is a step or two behind, his twitch and explosion (upper and lower body) is one of the best I have seen. I also think he brings the meanest personality to the table. Neal is the one with the biggest upside overall, but I also think he has the lowest floor. No, I am not hedging my bet here. My grade is above, and he is OT1 on my board. But what I mean here is, Neal’s biggest issue (balance) has ruined careers in this league. If you can’t stay on your feet, let alone stay solid and strong on them, you won’t be a reliable blocker against players that are just as fast east-west as they are north-south. Defensive schemes are also as complex as they’ve ever been. But his best tape rivals Hall of Famer Walter Jones, the top tackle of my lifetime in my opinion. While I would be surprised to see Cross go ahead of the two guys above, it has very little to do with his run blocking. My surprise would come from the fact that is there is a weakness to his pass blocking, it is the anchor and losing to the inside shoulder. This will very much depend on what Daboll wants out of the tackle. Does he want more body control and overall grace? Then, Cross makes sense. But I think he will lean more toward power for this vacant RT spot.</p>
<p>If NYG somehow ignores OT with the first two picks, they almost need to force a pick there at the top of round 2. There are quality linemen taken there in that window nearly every year, but more often than not it is an inside guy. Tackles in round 2 are not easy to find. Names like Abraham Lucas, Tyler Smith, Nicholas Petit-Frere may not present the best value at that point in the draft, but NYG would almost have to go in that direction. The OL is the biggest issue this team has had for years, right tackle in particular. Waiting and waiting and waiting is a recipe to create the same issues we have been forced to stress about.</p>
<p>My closing thought will not be a popular one. I am very much open to the idea of using BOTH #5 and #7 on two offensive linemen. I know some of the naysayers bring up the potential cap downfall of this in a few years, but I do not agree. NYG will not be paying a starting quarterback top-of-market price (unless Jones explodes and/or they trade for an established superstar, both good problems). When that is the case, you can be overly aggressive at a few different spots. Knowing how hard it is to find good offensive linemen (across the league), this is the spot I would invest in should a situation like this pop up. Remember, the offensive line is FIVE positions. In addition, it provides a hedge should one of the linemen not pan out and/or injuries arise. We will see what the decision and situation present draft weekend.</p>
<div class="printfriendly pf-button pf-button-content pf-alignright"><a href="#" rel="nofollow" onclick="window.print(); return false;" title="Printer Friendly, PDF &amp; Email"><img class="pf-button-img" src="https://cdn.printfriendly.com/buttons/print-button-nobg.png" alt="Print Friendly, PDF &amp; Email" style="width: 66px;height: 24px;"/></a></div></div>			</div><!--/entry -->

		</div><!-- .entry-container -->
<div class="author-info fix">
<h4>David Syvertsen</h4>
<img alt="" src="https://secure.gravatar.com/avatar/8dd345a35203a84f0da30466b919d9f3?s=64&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/8dd345a35203a84f0da30466b919d9f3?s=128&amp;d=mm&amp;r=g 2x" class="avatar avatar-64 photo" height="64" width="64" loading="lazy"/>David Syvertsen, aka Sy&#39;56, has worked for Ourlads Scouting LLC since 2013, starting off as a college depth chart manager and now a lead scout for one the most-sold NFL draft guides year-in, year-out. He has been scouting for over 10 years and will compile anywhere from 400-600 scouting reports per season, with that number increasing year by year. He watches and studies game films 20-25 hours per week throughout the entire year with his main focus being NFL Draft prospects.</div>
<footer class="post-footer postdata fix">
		<span class="category"><span class="icon"> </span><a href="https://www.bigblueinteractive.com/category/articles/" rel="category tag">Articles</a>, <a href="https://www.bigblueinteractive.com/category/articles/the-draft/" rel="category tag">The Draft</a></span>
		<span class="tags tax"><span class="icon"> </span>Tagged with: <a href="https://www.bigblueinteractive.com/tag/2022-nfl-draft/" rel="tag">2022 NFL Draft</a></span>
	</footer><!-- .post-footer -->
<section id="comments">
<p>Sorry, the comment form is closed at this time.</p></section>   <!-- #comments -->	
	</article>
	
	<!--/post -->
<nav class="post-nav fix">
<table>
<tbody><tr>
	<td class="previous"><a href="https://www.bigblueinteractive.com/2022/04/16/new-york-giants-2022-nfl-draft-preview-guards-centers/" rel="prev"><span class="icon"> </span> New York Giants 2022 NFL Draft Preview: Guards/Centers</a></td>
	<td class="next"></td>
</tr>
</tbody></table>
</nav>
      </div><!-- content -->
    </div><!-- main col -->
<div id="sidebar-wrap" class="sidebar-wrap sidebar-wrap-right fix">		<!-- #wsidebar-top -->
		<div id="wsidebar-top" class="dbx-group right boxed warea">
<!--widget start --><aside id="custom_html-2" class="widget_text dbx-box suf-widget widget_custom_html"><div class="widget_text dbx-content"><div class="textwidget custom-html-widget"><!-- SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.main -->
<div id="usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.main">
     <script type="text/javascript">
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103,22280986322/SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.main', [[300,250],[300,600]], 'usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.main').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.main');
         });
     </script>
</div></div></div></aside><!--widget end --><!--widget start --><aside id="wp_category_post_list_itg-2" class="dbx-box suf-widget widget_wp_category_post_list_itg"><div class="dbx-content"><h3 class="dbx-handle plain"><a href="https://www.bigblueinteractive.com/category/cornerposts/">Corner Forum Highlights</a></h3><ul class="wp-cpl-widget wp-cpl-theme-0"><li class="wp-cpl wp-cpl-even"><a href="https://corner.bigblueinteractive.com/index.php?mode=2&amp;thread=621266#new_tab" title="Permalink to: Forum Post: 2022 NFL Draft Preview - Offensive Tackle" target="_self">Forum Post: 2022 NFL Draft Preview - Offensive Tackle</a></li>
<li class="wp-cpl wp-cpl-odd"><a href="https://corner.bigblueinteractive.com/index.php?mode=2&amp;thread=621227#new_tab" title="Permalink to: Forum Post: 2022 NFL Draft Preview - Guard/Center" target="_self">Forum Post: 2022 NFL Draft Preview - Guard/Center</a></li>
<li class="wp-cpl wp-cpl-even"><a href="https://corner.bigblueinteractive.com/index.php?mode=2&amp;thread=621210#new_tab" title="Permalink to: Forum Post: Could #5 AND #7 picks both be o-line? (Neal and Ekwonu)" target="_self">Forum Post: Could #5 AND #7 picks both be o-line? (Neal and Ekwonu)</a></li>
<li class="wp-cpl wp-cpl-odd"><a href="https://corner.bigblueinteractive.com/index.php?mode=2&amp;thread=621200#new_tab" title="Permalink to: Forum Post: ESPN: Giants love Charles Cross" target="_self">Forum Post: ESPN: Giants love Charles Cross</a></li>
</ul><p class="wp-cpl-teaser">The Hottest Discussions in BBI&#39;s Corner Forum</p></div></aside><!--widget end --><!--widget start --><aside id="text-533808690" class="dbx-box suf-widget widget_text"><div class="dbx-content">			<div class="textwidget"><b><a href="https://www.bigblueinteractive.com/category/news-and-notes/"> Do you miss the old Front Page Layout? <br/> Click here to see it!</a></b></div>
		</div></aside><!--widget end --><!--widget start --><aside id="categories-2" class="dbx-box suf-widget widget_categories"><div class="dbx-content"><h3 class="dbx-handle plain">Content Sections</h3><form action="https://www.bigblueinteractive.com" method="get"><label class="screen-reader-text" for="cat">Content Sections</label><select name="cat" id="cat" class="postform">
	<option value="-1">Select Category</option>
	<option class="level-0" value="8">Articles  (1,228)</option>
	<option class="level-0" value="34">Corner Forum Highlights  (87)</option>
	<option class="level-0" value="390">Features  (117)</option>
	<option class="level-0" value="64">Game Previews and Reviews  (1,060)</option>
	<option class="level-0" value="60">Giant Thoughts  (43)</option>
	<option class="level-0" value="39">Media  (65)</option>
	<option class="level-0" value="40">New York Giants History  (23)</option>
	<option class="level-0" value="3">News and Notes  (3,865)</option>
	<option class="level-0" value="9">Roster Breakdown  (166)</option>
	<option class="level-0" value="82">The Draft  (251)</option>
	<option class="level-0" value="7">The Salary Cap  (17)</option>
	<option class="level-0" value="65">Training Camp  (369)</option>
	<option class="level-0" value="106">Website Business  (8)</option>
</select>
</form>
<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "cat" );
	function onCatChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value > 0 ) {
			dropdown.parentNode.submit();
		}
	}
	dropdown.onchange = onCatChange;
})();
/* ]]> */
</script>

			</div></aside><!--widget end --><!--widget start --><aside id="search-3" class="dbx-box suf-widget search"><div class="dbx-content">
<form method="get" class="searchform " action="https://www.bigblueinteractive.com/">
	<input type="text" name="s" class="searchfield" value="Search" onfocus="if (this.value == &#39;Search&#39;) {this.value = &#39;&#39;;}" onblur="if (this.value == &#39;&#39;) {this.value = &#39;Search&#39;;}"/>
	<input type="submit" class="searchsubmit" value="" name="searchsubmit"/>
</form>
</div></aside><!--widget end -->		</div>
		<!-- /#wsidebar-top -->
<div id="sidebar-shell-1" class="sidebar-shell sidebar-shell-right">
<div class="dbx-group right flattened warea" id="sidebar">
<!--widget start --><aside id="media_image-2" class="suf-flat-widget widget_media_image"><a href="http://web.yesnetwork.com/"><img width="246" height="127" src="https://www.bigblueinteractive.com/wp-content/uploads/YES-Logo-November-2020-cropped.png" class="image wp-image-101239  attachment-full size-full" alt="Yes Network Logo" loading="lazy" style="max-width: 100%; height: auto;" srcset="https://www.bigblueinteractive.com/wp-content/uploads/YES-Logo-November-2020-cropped.png 246w, https://www.bigblueinteractive.com/wp-content/uploads/YES-Logo-November-2020-cropped-150x77.png 150w" sizes="(max-width: 246px) 100vw, 246px"/></a></aside><!--widget end --></div><!--/sidebar -->
</div>
<div id="sidebar-shell-2" class="sidebar-shell sidebar-shell-right">
<div class="dbx-group right boxed warea" id="sidebar-2">

  
</div><!--/sidebar-2 -->
</div>
		<!-- #wsidebar-bottom -->
		<div id="wsidebar-bottom" class="dbx-group right boxed warea">
<!--widget start --><aside id="archives-2" class="dbx-box suf-widget widget_archive"><div class="dbx-content"><h3 class="dbx-handle plain">Posts By Month</h3>		<label class="screen-reader-text" for="archives-dropdown-2">Posts By Month</label>
		<select id="archives-dropdown-2" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value="https://www.bigblueinteractive.com/2022/04/"> April 2022  (38)</option>
	<option value="https://www.bigblueinteractive.com/2022/03/"> March 2022  (81)</option>
	<option value="https://www.bigblueinteractive.com/2022/02/"> February 2022  (17)</option>
	<option value="https://www.bigblueinteractive.com/2022/01/"> January 2022  (27)</option>
	<option value="https://www.bigblueinteractive.com/2021/12/"> December 2021  (31)</option>
	<option value="https://www.bigblueinteractive.com/2021/11/"> November 2021  (29)</option>
	<option value="https://www.bigblueinteractive.com/2021/10/"> October 2021  (32)</option>
	<option value="https://www.bigblueinteractive.com/2021/09/"> September 2021  (26)</option>
	<option value="https://www.bigblueinteractive.com/2021/08/"> August 2021  (33)</option>
	<option value="https://www.bigblueinteractive.com/2021/07/"> July 2021  (9)</option>
	<option value="https://www.bigblueinteractive.com/2021/06/"> June 2021  (6)</option>
	<option value="https://www.bigblueinteractive.com/2021/05/"> May 2021  (10)</option>
	<option value="https://www.bigblueinteractive.com/2021/04/"> April 2021  (19)</option>
	<option value="https://www.bigblueinteractive.com/2021/03/"> March 2021  (26)</option>
	<option value="https://www.bigblueinteractive.com/2021/02/"> February 2021  (8)</option>
	<option value="https://www.bigblueinteractive.com/2021/01/"> January 2021  (18)</option>
	<option value="https://www.bigblueinteractive.com/2020/12/"> December 2020  (34)</option>
	<option value="https://www.bigblueinteractive.com/2020/11/"> November 2020  (28)</option>
	<option value="https://www.bigblueinteractive.com/2020/10/"> October 2020  (31)</option>
	<option value="https://www.bigblueinteractive.com/2020/09/"> September 2020  (32)</option>
	<option value="https://www.bigblueinteractive.com/2020/08/"> August 2020  (28)</option>
	<option value="https://www.bigblueinteractive.com/2020/07/"> July 2020  (12)</option>
	<option value="https://www.bigblueinteractive.com/2020/06/"> June 2020  (7)</option>
	<option value="https://www.bigblueinteractive.com/2020/05/"> May 2020  (14)</option>
	<option value="https://www.bigblueinteractive.com/2020/04/"> April 2020  (28)</option>
	<option value="https://www.bigblueinteractive.com/2020/03/"> March 2020  (22)</option>
	<option value="https://www.bigblueinteractive.com/2020/02/"> February 2020  (4)</option>
	<option value="https://www.bigblueinteractive.com/2020/01/"> January 2020  (17)</option>
	<option value="https://www.bigblueinteractive.com/2019/12/"> December 2019  (34)</option>
	<option value="https://www.bigblueinteractive.com/2019/11/"> November 2019  (26)</option>
	<option value="https://www.bigblueinteractive.com/2019/10/"> October 2019  (31)</option>
	<option value="https://www.bigblueinteractive.com/2019/09/"> September 2019  (31)</option>
	<option value="https://www.bigblueinteractive.com/2019/08/"> August 2019  (32)</option>
	<option value="https://www.bigblueinteractive.com/2019/07/"> July 2019  (14)</option>
	<option value="https://www.bigblueinteractive.com/2019/06/"> June 2019  (14)</option>
	<option value="https://www.bigblueinteractive.com/2019/05/"> May 2019  (15)</option>
	<option value="https://www.bigblueinteractive.com/2019/04/"> April 2019  (22)</option>
	<option value="https://www.bigblueinteractive.com/2019/03/"> March 2019  (15)</option>
	<option value="https://www.bigblueinteractive.com/2019/02/"> February 2019  (14)</option>
	<option value="https://www.bigblueinteractive.com/2019/01/"> January 2019  (7)</option>
	<option value="https://www.bigblueinteractive.com/2018/12/"> December 2018  (33)</option>
	<option value="https://www.bigblueinteractive.com/2018/11/"> November 2018  (26)</option>
	<option value="https://www.bigblueinteractive.com/2018/10/"> October 2018  (31)</option>
	<option value="https://www.bigblueinteractive.com/2018/09/"> September 2018  (31)</option>
	<option value="https://www.bigblueinteractive.com/2018/08/"> August 2018  (33)</option>
	<option value="https://www.bigblueinteractive.com/2018/07/"> July 2018  (16)</option>
	<option value="https://www.bigblueinteractive.com/2018/06/"> June 2018  (13)</option>
	<option value="https://www.bigblueinteractive.com/2018/05/"> May 2018  (13)</option>
	<option value="https://www.bigblueinteractive.com/2018/04/"> April 2018  (32)</option>
	<option value="https://www.bigblueinteractive.com/2018/03/"> March 2018  (25)</option>
	<option value="https://www.bigblueinteractive.com/2018/02/"> February 2018  (7)</option>
	<option value="https://www.bigblueinteractive.com/2018/01/"> January 2018  (21)</option>
	<option value="https://www.bigblueinteractive.com/2017/12/"> December 2017  (36)</option>
	<option value="https://www.bigblueinteractive.com/2017/11/"> November 2017  (33)</option>
	<option value="https://www.bigblueinteractive.com/2017/10/"> October 2017  (32)</option>
	<option value="https://www.bigblueinteractive.com/2017/09/"> September 2017  (33)</option>
	<option value="https://www.bigblueinteractive.com/2017/08/"> August 2017  (33)</option>
	<option value="https://www.bigblueinteractive.com/2017/07/"> July 2017  (19)</option>
	<option value="https://www.bigblueinteractive.com/2017/06/"> June 2017  (9)</option>
	<option value="https://www.bigblueinteractive.com/2017/05/"> May 2017  (14)</option>
	<option value="https://www.bigblueinteractive.com/2017/04/"> April 2017  (34)</option>
	<option value="https://www.bigblueinteractive.com/2017/03/"> March 2017  (32)</option>
	<option value="https://www.bigblueinteractive.com/2017/02/"> February 2017  (18)</option>
	<option value="https://www.bigblueinteractive.com/2017/01/"> January 2017  (19)</option>
	<option value="https://www.bigblueinteractive.com/2016/12/"> December 2016  (43)</option>
	<option value="https://www.bigblueinteractive.com/2016/11/"> November 2016  (34)</option>
	<option value="https://www.bigblueinteractive.com/2016/10/"> October 2016  (31)</option>
	<option value="https://www.bigblueinteractive.com/2016/09/"> September 2016  (33)</option>
	<option value="https://www.bigblueinteractive.com/2016/08/"> August 2016  (33)</option>
	<option value="https://www.bigblueinteractive.com/2016/07/"> July 2016  (10)</option>
	<option value="https://www.bigblueinteractive.com/2016/06/"> June 2016  (10)</option>
	<option value="https://www.bigblueinteractive.com/2016/05/"> May 2016  (16)</option>
	<option value="https://www.bigblueinteractive.com/2016/04/"> April 2016  (32)</option>
	<option value="https://www.bigblueinteractive.com/2016/03/"> March 2016  (35)</option>
	<option value="https://www.bigblueinteractive.com/2016/02/"> February 2016  (22)</option>
	<option value="https://www.bigblueinteractive.com/2016/01/"> January 2016  (43)</option>
	<option value="https://www.bigblueinteractive.com/2015/12/"> December 2015  (45)</option>
	<option value="https://www.bigblueinteractive.com/2015/11/"> November 2015  (32)</option>
	<option value="https://www.bigblueinteractive.com/2015/10/"> October 2015  (41)</option>
	<option value="https://www.bigblueinteractive.com/2015/09/"> September 2015  (40)</option>
	<option value="https://www.bigblueinteractive.com/2015/08/"> August 2015  (36)</option>
	<option value="https://www.bigblueinteractive.com/2015/07/"> July 2015  (35)</option>
	<option value="https://www.bigblueinteractive.com/2015/06/"> June 2015  (25)</option>
	<option value="https://www.bigblueinteractive.com/2015/05/"> May 2015  (29)</option>
	<option value="https://www.bigblueinteractive.com/2015/04/"> April 2015  (31)</option>
	<option value="https://www.bigblueinteractive.com/2015/03/"> March 2015  (49)</option>
	<option value="https://www.bigblueinteractive.com/2015/02/"> February 2015  (24)</option>
	<option value="https://www.bigblueinteractive.com/2015/01/"> January 2015  (32)</option>
	<option value="https://www.bigblueinteractive.com/2014/12/"> December 2014  (47)</option>
	<option value="https://www.bigblueinteractive.com/2014/11/"> November 2014  (37)</option>
	<option value="https://www.bigblueinteractive.com/2014/10/"> October 2014  (37)</option>
	<option value="https://www.bigblueinteractive.com/2014/09/"> September 2014  (49)</option>
	<option value="https://www.bigblueinteractive.com/2014/08/"> August 2014  (84)</option>
	<option value="https://www.bigblueinteractive.com/2014/07/"> July 2014  (89)</option>
	<option value="https://www.bigblueinteractive.com/2014/06/"> June 2014  (46)</option>
	<option value="https://www.bigblueinteractive.com/2014/05/"> May 2014  (47)</option>
	<option value="https://www.bigblueinteractive.com/2014/04/"> April 2014  (41)</option>
	<option value="https://www.bigblueinteractive.com/2014/03/"> March 2014  (46)</option>
	<option value="https://www.bigblueinteractive.com/2014/02/"> February 2014  (17)</option>
	<option value="https://www.bigblueinteractive.com/2014/01/"> January 2014  (36)</option>
	<option value="https://www.bigblueinteractive.com/2013/12/"> December 2013  (51)</option>
	<option value="https://www.bigblueinteractive.com/2013/11/"> November 2013  (38)</option>
	<option value="https://www.bigblueinteractive.com/2013/10/"> October 2013  (41)</option>
	<option value="https://www.bigblueinteractive.com/2013/09/"> September 2013  (40)</option>
	<option value="https://www.bigblueinteractive.com/2013/08/"> August 2013  (48)</option>
	<option value="https://www.bigblueinteractive.com/2013/07/"> July 2013  (35)</option>
	<option value="https://www.bigblueinteractive.com/2013/06/"> June 2013  (25)</option>
	<option value="https://www.bigblueinteractive.com/2013/05/"> May 2013  (28)</option>
	<option value="https://www.bigblueinteractive.com/2013/04/"> April 2013  (34)</option>
	<option value="https://www.bigblueinteractive.com/2013/03/"> March 2013  (24)</option>
	<option value="https://www.bigblueinteractive.com/2013/02/"> February 2013  (16)</option>
	<option value="https://www.bigblueinteractive.com/2013/01/"> January 2013  (15)</option>
	<option value="https://www.bigblueinteractive.com/2012/12/"> December 2012  (36)</option>
	<option value="https://www.bigblueinteractive.com/2012/11/"> November 2012  (33)</option>
	<option value="https://www.bigblueinteractive.com/2012/10/"> October 2012  (37)</option>
	<option value="https://www.bigblueinteractive.com/2012/09/"> September 2012  (35)</option>
	<option value="https://www.bigblueinteractive.com/2012/08/"> August 2012  (56)</option>
	<option value="https://www.bigblueinteractive.com/2012/07/"> July 2012  (28)</option>
	<option value="https://www.bigblueinteractive.com/2012/06/"> June 2012  (20)</option>
	<option value="https://www.bigblueinteractive.com/2012/05/"> May 2012  (21)</option>
	<option value="https://www.bigblueinteractive.com/2012/04/"> April 2012  (18)</option>
	<option value="https://www.bigblueinteractive.com/2012/03/"> March 2012  (22)</option>
	<option value="https://www.bigblueinteractive.com/2012/02/"> February 2012  (20)</option>
	<option value="https://www.bigblueinteractive.com/2012/01/"> January 2012  (39)</option>
	<option value="https://www.bigblueinteractive.com/2011/12/"> December 2011  (39)</option>
	<option value="https://www.bigblueinteractive.com/2011/11/"> November 2011  (35)</option>
	<option value="https://www.bigblueinteractive.com/2011/10/"> October 2011  (34)</option>
	<option value="https://www.bigblueinteractive.com/2011/09/"> September 2011  (36)</option>
	<option value="https://www.bigblueinteractive.com/2011/08/"> August 2011  (41)</option>
	<option value="https://www.bigblueinteractive.com/2011/07/"> July 2011  (18)</option>
	<option value="https://www.bigblueinteractive.com/2011/06/"> June 2011  (15)</option>
	<option value="https://www.bigblueinteractive.com/2011/05/"> May 2011  (10)</option>
	<option value="https://www.bigblueinteractive.com/2011/04/"> April 2011  (9)</option>
	<option value="https://www.bigblueinteractive.com/2011/03/"> March 2011  (9)</option>
	<option value="https://www.bigblueinteractive.com/2011/02/"> February 2011  (11)</option>
	<option value="https://www.bigblueinteractive.com/2011/01/"> January 2011  (14)</option>
	<option value="https://www.bigblueinteractive.com/2010/12/"> December 2010  (41)</option>
	<option value="https://www.bigblueinteractive.com/2010/11/"> November 2010  (38)</option>
	<option value="https://www.bigblueinteractive.com/2010/10/"> October 2010  (37)</option>
	<option value="https://www.bigblueinteractive.com/2010/09/"> September 2010  (41)</option>
	<option value="https://www.bigblueinteractive.com/2010/08/"> August 2010  (52)</option>
	<option value="https://www.bigblueinteractive.com/2010/07/"> July 2010  (13)</option>
	<option value="https://www.bigblueinteractive.com/2010/06/"> June 2010  (14)</option>
	<option value="https://www.bigblueinteractive.com/2010/05/"> May 2010  (15)</option>
	<option value="https://www.bigblueinteractive.com/2010/04/"> April 2010  (22)</option>
	<option value="https://www.bigblueinteractive.com/2010/03/"> March 2010  (17)</option>
	<option value="https://www.bigblueinteractive.com/2010/02/"> February 2010  (15)</option>
	<option value="https://www.bigblueinteractive.com/2010/01/"> January 2010  (20)</option>
	<option value="https://www.bigblueinteractive.com/2009/12/"> December 2009  (44)</option>
	<option value="https://www.bigblueinteractive.com/2009/11/"> November 2009  (29)</option>
	<option value="https://www.bigblueinteractive.com/2009/10/"> October 2009  (42)</option>
	<option value="https://www.bigblueinteractive.com/2009/09/"> September 2009  (41)</option>
	<option value="https://www.bigblueinteractive.com/2009/08/"> August 2009  (55)</option>
	<option value="https://www.bigblueinteractive.com/2009/07/"> July 2009  (11)</option>
	<option value="https://www.bigblueinteractive.com/2009/06/"> June 2009  (13)</option>
	<option value="https://www.bigblueinteractive.com/2009/05/"> May 2009  (10)</option>
	<option value="https://www.bigblueinteractive.com/2009/04/"> April 2009  (17)</option>
	<option value="https://www.bigblueinteractive.com/2009/03/"> March 2009  (14)</option>
	<option value="https://www.bigblueinteractive.com/2009/02/"> February 2009  (17)</option>
	<option value="https://www.bigblueinteractive.com/2009/01/"> January 2009  (27)</option>
	<option value="https://www.bigblueinteractive.com/2008/12/"> December 2008  (40)</option>
	<option value="https://www.bigblueinteractive.com/2008/11/"> November 2008  (36)</option>
	<option value="https://www.bigblueinteractive.com/2008/10/"> October 2008  (36)</option>
	<option value="https://www.bigblueinteractive.com/2008/09/"> September 2008  (27)</option>
	<option value="https://www.bigblueinteractive.com/2008/08/"> August 2008  (48)</option>
	<option value="https://www.bigblueinteractive.com/2008/07/"> July 2008  (26)</option>
	<option value="https://www.bigblueinteractive.com/2008/06/"> June 2008  (19)</option>
	<option value="https://www.bigblueinteractive.com/2008/05/"> May 2008  (19)</option>
	<option value="https://www.bigblueinteractive.com/2008/04/"> April 2008  (25)</option>
	<option value="https://www.bigblueinteractive.com/2008/03/"> March 2008  (19)</option>
	<option value="https://www.bigblueinteractive.com/2008/02/"> February 2008  (28)</option>
	<option value="https://www.bigblueinteractive.com/2008/01/"> January 2008  (39)</option>
	<option value="https://www.bigblueinteractive.com/2007/12/"> December 2007  (40)</option>
	<option value="https://www.bigblueinteractive.com/2007/11/"> November 2007  (35)</option>
	<option value="https://www.bigblueinteractive.com/2007/10/"> October 2007  (37)</option>
	<option value="https://www.bigblueinteractive.com/2007/09/"> September 2007  (35)</option>
	<option value="https://www.bigblueinteractive.com/2007/08/"> August 2007  (59)</option>
	<option value="https://www.bigblueinteractive.com/2007/07/"> July 2007  (19)</option>
	<option value="https://www.bigblueinteractive.com/2007/06/"> June 2007  (10)</option>
	<option value="https://www.bigblueinteractive.com/2007/05/"> May 2007  (21)</option>
	<option value="https://www.bigblueinteractive.com/2007/04/"> April 2007  (22)</option>
	<option value="https://www.bigblueinteractive.com/2007/03/"> March 2007  (28)</option>
	<option value="https://www.bigblueinteractive.com/2007/02/"> February 2007  (20)</option>
	<option value="https://www.bigblueinteractive.com/2007/01/"> January 2007  (28)</option>
	<option value="https://www.bigblueinteractive.com/2006/12/"> December 2006  (35)</option>
	<option value="https://www.bigblueinteractive.com/2006/11/"> November 2006  (35)</option>
	<option value="https://www.bigblueinteractive.com/2006/10/"> October 2006  (30)</option>
	<option value="https://www.bigblueinteractive.com/2006/09/"> September 2006  (29)</option>
	<option value="https://www.bigblueinteractive.com/2006/08/"> August 2006  (60)</option>
	<option value="https://www.bigblueinteractive.com/2006/07/"> July 2006  (22)</option>
	<option value="https://www.bigblueinteractive.com/2006/06/"> June 2006  (16)</option>
	<option value="https://www.bigblueinteractive.com/2006/05/"> May 2006  (18)</option>
	<option value="https://www.bigblueinteractive.com/2006/04/"> April 2006  (4)</option>
	<option value="https://www.bigblueinteractive.com/2006/02/"> February 2006  (2)</option>
	<option value="https://www.bigblueinteractive.com/2006/01/"> January 2006  (3)</option>
	<option value="https://www.bigblueinteractive.com/2005/12/"> December 2005  (9)</option>
	<option value="https://www.bigblueinteractive.com/2005/11/"> November 2005  (10)</option>
	<option value="https://www.bigblueinteractive.com/2005/10/"> October 2005  (7)</option>
	<option value="https://www.bigblueinteractive.com/2005/09/"> September 2005  (8)</option>
	<option value="https://www.bigblueinteractive.com/2005/08/"> August 2005  (18)</option>
	<option value="https://www.bigblueinteractive.com/2005/07/"> July 2005  (9)</option>
	<option value="https://www.bigblueinteractive.com/2005/04/"> April 2005  (2)</option>
	<option value="https://www.bigblueinteractive.com/2005/02/"> February 2005  (1)</option>
	<option value="https://www.bigblueinteractive.com/2005/01/"> January 2005  (1)</option>
	<option value="https://www.bigblueinteractive.com/2004/12/"> December 2004  (11)</option>
	<option value="https://www.bigblueinteractive.com/2004/11/"> November 2004  (8)</option>
	<option value="https://www.bigblueinteractive.com/2004/10/"> October 2004  (7)</option>
	<option value="https://www.bigblueinteractive.com/2004/09/"> September 2004  (11)</option>
	<option value="https://www.bigblueinteractive.com/2004/08/"> August 2004  (10)</option>
	<option value="https://www.bigblueinteractive.com/2004/07/"> July 2004  (1)</option>
	<option value="https://www.bigblueinteractive.com/2004/06/"> June 2004  (1)</option>
	<option value="https://www.bigblueinteractive.com/2004/04/"> April 2004  (3)</option>
	<option value="https://www.bigblueinteractive.com/2004/03/"> March 2004  (2)</option>
	<option value="https://www.bigblueinteractive.com/2004/02/"> February 2004  (2)</option>
	<option value="https://www.bigblueinteractive.com/2004/01/"> January 2004  (1)</option>
	<option value="https://www.bigblueinteractive.com/2003/12/"> December 2003  (10)</option>
	<option value="https://www.bigblueinteractive.com/2003/11/"> November 2003  (8)</option>
	<option value="https://www.bigblueinteractive.com/2003/10/"> October 2003  (9)</option>
	<option value="https://www.bigblueinteractive.com/2003/09/"> September 2003  (7)</option>
	<option value="https://www.bigblueinteractive.com/2003/08/"> August 2003  (19)</option>
	<option value="https://www.bigblueinteractive.com/2003/07/"> July 2003  (2)</option>
	<option value="https://www.bigblueinteractive.com/2003/06/"> June 2003  (2)</option>
	<option value="https://www.bigblueinteractive.com/2003/05/"> May 2003  (1)</option>
	<option value="https://www.bigblueinteractive.com/2003/04/"> April 2003  (4)</option>
	<option value="https://www.bigblueinteractive.com/2003/02/"> February 2003  (1)</option>
	<option value="https://www.bigblueinteractive.com/2003/01/"> January 2003  (3)</option>
	<option value="https://www.bigblueinteractive.com/2002/12/"> December 2002  (9)</option>
	<option value="https://www.bigblueinteractive.com/2002/11/"> November 2002  (9)</option>
	<option value="https://www.bigblueinteractive.com/2002/10/"> October 2002  (10)</option>
	<option value="https://www.bigblueinteractive.com/2002/09/"> September 2002  (9)</option>
	<option value="https://www.bigblueinteractive.com/2002/08/"> August 2002  (21)</option>
	<option value="https://www.bigblueinteractive.com/2002/07/"> July 2002  (4)</option>
	<option value="https://www.bigblueinteractive.com/2002/05/"> May 2002  (4)</option>
	<option value="https://www.bigblueinteractive.com/2002/04/"> April 2002  (3)</option>
	<option value="https://www.bigblueinteractive.com/2002/03/"> March 2002  (1)</option>
	<option value="https://www.bigblueinteractive.com/2002/02/"> February 2002  (1)</option>
	<option value="https://www.bigblueinteractive.com/2002/01/"> January 2002  (3)</option>
	<option value="https://www.bigblueinteractive.com/2001/12/"> December 2001  (8)</option>
	<option value="https://www.bigblueinteractive.com/2001/11/"> November 2001  (8)</option>
	<option value="https://www.bigblueinteractive.com/2001/10/"> October 2001  (11)</option>
	<option value="https://www.bigblueinteractive.com/2001/09/"> September 2001  (7)</option>
	<option value="https://www.bigblueinteractive.com/2001/08/"> August 2001  (13)</option>
	<option value="https://www.bigblueinteractive.com/2001/07/"> July 2001  (3)</option>
	<option value="https://www.bigblueinteractive.com/2001/05/"> May 2001  (1)</option>
	<option value="https://www.bigblueinteractive.com/2001/04/"> April 2001  (2)</option>
	<option value="https://www.bigblueinteractive.com/2001/02/"> February 2001  (2)</option>
	<option value="https://www.bigblueinteractive.com/2001/01/"> January 2001  (6)</option>
	<option value="https://www.bigblueinteractive.com/2000/12/"> December 2000  (8)</option>
	<option value="https://www.bigblueinteractive.com/2000/11/"> November 2000  (9)</option>
	<option value="https://www.bigblueinteractive.com/2000/10/"> October 2000  (6)</option>
	<option value="https://www.bigblueinteractive.com/2000/09/"> September 2000  (9)</option>
	<option value="https://www.bigblueinteractive.com/2000/08/"> August 2000  (9)</option>
	<option value="https://www.bigblueinteractive.com/2000/07/"> July 2000  (2)</option>
	<option value="https://www.bigblueinteractive.com/2000/06/"> June 2000  (1)</option>
	<option value="https://www.bigblueinteractive.com/2000/04/"> April 2000  (5)</option>
	<option value="https://www.bigblueinteractive.com/2000/02/"> February 2000  (1)</option>
	<option value="https://www.bigblueinteractive.com/2000/01/"> January 2000  (2)</option>
	<option value="https://www.bigblueinteractive.com/1999/12/"> December 1999  (10)</option>
	<option value="https://www.bigblueinteractive.com/1999/11/"> November 1999  (6)</option>
	<option value="https://www.bigblueinteractive.com/1999/10/"> October 1999  (9)</option>
	<option value="https://www.bigblueinteractive.com/1999/09/"> September 1999  (8)</option>
	<option value="https://www.bigblueinteractive.com/1999/08/"> August 1999  (6)</option>
	<option value="https://www.bigblueinteractive.com/1999/07/"> July 1999  (2)</option>
	<option value="https://www.bigblueinteractive.com/1999/04/"> April 1999  (2)</option>
	<option value="https://www.bigblueinteractive.com/1999/03/"> March 1999  (1)</option>
	<option value="https://www.bigblueinteractive.com/1999/02/"> February 1999  (1)</option>
	<option value="https://www.bigblueinteractive.com/1998/12/"> December 1998  (9)</option>
	<option value="https://www.bigblueinteractive.com/1998/11/"> November 1998  (8)</option>
	<option value="https://www.bigblueinteractive.com/1998/10/"> October 1998  (7)</option>
	<option value="https://www.bigblueinteractive.com/1998/09/"> September 1998  (8)</option>
	<option value="https://www.bigblueinteractive.com/1998/08/"> August 1998  (8)</option>
	<option value="https://www.bigblueinteractive.com/1998/07/"> July 1998  (2)</option>
	<option value="https://www.bigblueinteractive.com/1998/04/"> April 1998  (2)</option>
	<option value="https://www.bigblueinteractive.com/1998/03/"> March 1998  (1)</option>
	<option value="https://www.bigblueinteractive.com/1998/02/"> February 1998  (1)</option>
	<option value="https://www.bigblueinteractive.com/1997/12/"> December 1997  (9)</option>
	<option value="https://www.bigblueinteractive.com/1997/11/"> November 1997  (8)</option>
	<option value="https://www.bigblueinteractive.com/1997/10/"> October 1997  (10)</option>
	<option value="https://www.bigblueinteractive.com/1997/09/"> September 1997  (8)</option>
	<option value="https://www.bigblueinteractive.com/1997/08/"> August 1997  (8)</option>
	<option value="https://www.bigblueinteractive.com/1997/07/"> July 1997  (3)</option>
	<option value="https://www.bigblueinteractive.com/1997/06/"> June 1997  (1)</option>
	<option value="https://www.bigblueinteractive.com/1997/04/"> April 1997  (1)</option>
	<option value="https://www.bigblueinteractive.com/1997/03/"> March 1997  (1)</option>
	<option value="https://www.bigblueinteractive.com/1996/12/"> December 1996  (7)</option>
	<option value="https://www.bigblueinteractive.com/1996/11/"> November 1996  (9)</option>
	<option value="https://www.bigblueinteractive.com/1996/10/"> October 1996  (6)</option>
	<option value="https://www.bigblueinteractive.com/1996/09/"> September 1996  (5)</option>
	<option value="https://www.bigblueinteractive.com/1996/08/"> August 1996  (5)</option>
	<option value="https://www.bigblueinteractive.com/1996/07/"> July 1996  (1)</option>
	<option value="https://www.bigblueinteractive.com/1996/05/"> May 1996  (1)</option>
	<option value="https://www.bigblueinteractive.com/1996/04/"> April 1996  (2)</option>
	<option value="https://www.bigblueinteractive.com/1995/07/"> July 1995  (1)</option>
	<option value="https://www.bigblueinteractive.com/1995/05/"> May 1995  (1)</option>
	<option value="https://www.bigblueinteractive.com/2022/04/">  0  (1)</option>

		</select>

<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-2" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
			</div></aside><!--widget end --><!--widget start --><aside id="text-533808692" class="dbx-box suf-widget widget_text"><div class="dbx-content">			<div class="textwidget"><!-- Ezoic - ROS Lower Box (AdSense) - sidebar_middle -->
<div id="ezoic-pub-ad-placeholder-103">
<script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- ROS - Lower 300x250 Box -->
<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-1566320450447229" data-ad-slot="8997951193"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- End Ezoic - ROS Lower Box (AdSense) - sidebar_middle --></div>
		</div></aside><!--widget end --><!--widget start --><aside id="text-533808694" class="dbx-box suf-widget widget_text"><div class="dbx-content">			<div class="textwidget"></div>
		</div></aside><!--widget end --><!--widget start --><aside id="custom_html-4" class="widget_text dbx-box suf-widget widget_custom_html"><div class="widget_text dbx-content"><div class="textwidget custom-html-widget"><div style="text-align:center;">
<a href="http://pcqb.com" rel="nofollow"><img src="/images/pcqb-we-fix-broken-sites.png" title="Site managed by PCQB WordPress Support" alt="We Fix Broken Websites"/></a>
</div></div></div></aside><!--widget end -->		</div>
		<!-- /#wsidebar-bottom -->
</div>	</div><!-- /container -->

<footer>
	<div id="cred">
		<table>
			<tbody><tr>
				<td class="cred-left">	<p><b>Part of the USA Today Sports Media Group</b><br/>
BigBlueInteractive<sup>SM</sup> provides news, analysis, and discussion on the New York Football Giants. The site is owned and operated by Big Blue Interactive, LLC.  If you
have any questions or comments about this website, please see our <a href="https://www.bigblueinteractive.com/information-pages/contact-us/">contact information page</a>.

</p>
</td>
				<td class="cred-center"> </td>
				<td class="cred-right"><p>
All contents (unless otherwise specified) copyright ©  1995 - 2021
Big Blue Interactive, LLC. All Rights Reserved.<br/>Site Managed by<br/> <a href="http://www.pcqb.com/" target="new" rel-"nofollow"="">PCQB WordPress Support</a>
</p>
</td>
			</tr>
		</tbody></table>
	</div>
</footer>
<!-- 68 queries, 38MB in 0.842 seconds. -->
</div><!--/wrapper -->
<!-- location footer -->
     <script type="text/javascript" id="pf_script">
                      var pfHeaderImgUrl = '';
          var pfHeaderTagline = '';
          var pfdisableClickToDel = '0';
          var pfImagesSize = 'full-size';
          var pfImageDisplayStyle = 'right';
          var pfEncodeImages = '0';
          var pfShowHiddenContent  = '0';
          var pfDisableEmail = '0';
          var pfDisablePDF = '0';
          var pfDisablePrint = '0';
          var pfCustomCSS = '';
        var pfPlatform = 'WordPress';

        (function($){
            $(document).ready(function(){
                if($('.pf-button-content').length === 0){
                    $('style#pf-excerpt-styles').remove();
                }
            });
        })(jQuery);
        </script>
      <script async="" src="https://cdn.printfriendly.com/printfriendly.js"></script>
            <script type="text/javascript" src="https://www.bigblueinteractive.com/wp-includes/js/comment-reply.min.js?ver=5.7.5" id="comment-reply-js"></script>
<script type="text/javascript" id="qppr_frontend_scripts-js-extra">
/* <![CDATA[ */
var qpprFrontData = {"linkData":[],"siteURL":"https:\/\/www.bigblueinteractive.com","siteURLq":"https:\/\/www.bigblueinteractive.com"};
/* ]]> */
</script>
<script type="text/javascript" src="https://www.bigblueinteractive.com/wp-content/plugins/quick-pagepost-redirect-plugin/js/qppr_frontend_script.min.js?ver=5.2.2" id="qppr_frontend_scripts-js"></script>
<script type="text/javascript" src="https://www.bigblueinteractive.com/wp-content/plugins/page-links-to/dist/new-tab.js?ver=3.3.6" id="page-links-to-js"></script>
<script type="text/javascript" src="https://www.bigblueinteractive.com/wp-includes/js/wp-embed.min.js?ver=5.7.5" id="wp-embed-js"></script>
<!-- SMG_BigBlueInteractive/skin/sports/football/nfl.main -->
<div id="usmg_ad_SMG_BigBlueInteractive_skin_sports_football_nfl.main">
     <script type="text/javascript">
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103,22280986322/SMG_BigBlueInteractive/skin/sports/football/nfl.main', [1,1], 'usmg_ad_SMG_BigBlueInteractive_skin_sports_football_nfl.main').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_skin_sports_football_nfl.main');
         });
     </script>
</div>


<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '/detroitchicago/edmonton.webp?a=a&cb=1&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '/porpoiseant/jellyfish.webp?a=a&cb=1&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="bigblueinteractive_com",_audins_did=124135;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=195-1");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.bigblueinteractive_com,DomainId.124135" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=1&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script>
<script>__ez.queue.addFile('/beardeddragon/drake.js', '/beardeddragon/drake.js?gcb=1&cb=2', false, [], true, false, true, false);</script></body></html>