<!DOCTYPE html><!--[if IE 6]> <html id="ie6" lang="en-US"> <![endif]--><!--[if IE 7]> <html id="ie7" lang="en-US"> <![endif]--><!--[if IE 8]> <html id="ie8" lang="en-US"> <![endif]--><!--[if !(IE 6) | !(IE 7) | !(IE 8)]><!--><html lang="en-US"><!--<![endif]--><head><meta charset="UTF-8"/>
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=194-0&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=194-0&cb=3', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=194-0&cb=5', false, [], true, false, true, false);</script>
	
	<link rel="pingback" href="http://www.bigblueinteractive.com/xmlrpc.php"/>

	<!--[if lt IE 9]>
	<script src="http://www.bigblueinteractive.com/wp-content/themes/suffusion/scripts/html5.js" type="text/javascript"></script>
	<![endif]-->
<title>Dave Gettleman and Kevin Abrams Address the Media; Giants Cut Ryan Lewis</title>
<link rel="dns-prefetch" href="https://static.hupso.com/share/js/counters.js"/><link rel="preconnect" href="https://static.hupso.com/share/js/counters.js"/><link rel="preload" href="https://static.hupso.com/share/js/counters.js"/><meta property="og:image" content="http://www.bigblueinteractive.com/wp-content/uploads/Dave-Gettleman-New-York-Giants-February-25-2020-300x200.jpg"/>
<!-- This site is optimized with the Yoast SEO plugin v12.3 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="New York Giants General Manager Dave Gettleman and Assistant General Manager Kevin Abrams addressed the media on Tuesday. Giants cut CB Ryan Lewis."/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="http://www.bigblueinteractive.com/2021/04/20/dave-gettleman-and-kevin-abrams-address-the-media-giants-cut-ryan-lewis/"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="article"/>
<meta property="og:title" content="Dave Gettleman and Kevin Abrams Address the Media; Giants Cut Ryan Lewis"/>
<meta property="og:description" content="New York Giants General Manager Dave Gettleman and Assistant General Manager Kevin Abrams addressed the media on Tuesday. Giants cut CB Ryan Lewis."/>
<meta property="og:url" content="http://www.bigblueinteractive.com/2021/04/20/dave-gettleman-and-kevin-abrams-address-the-media-giants-cut-ryan-lewis/"/>
<meta property="og:site_name" content="Big Blue Interactive"/>
<meta property="article:author" content="https://www.facebook.com/BigBlueInteract"/>
<meta property="article:tag" content="Dave Gettleman"/>
<meta property="article:tag" content="Kevin Abrams"/>
<meta property="article:tag" content="Ryan Lewis"/>
<meta property="article:tag" content="Sandro Platzgummer"/>
<meta property="article:section" content="News and Notes"/>
<meta property="article:published_time" content="2021-04-20T19:59:22+00:00"/>
<meta property="og:image" content="http://www.bigblueinteractive.com/wp-content/uploads/Dave-Gettleman-New-York-Giants-February-25-2020.jpg"/>
<meta property="og:image:width" content="650"/>
<meta property="og:image:height" content="434"/>
<meta name="twitter:card" content="summary"/>
<meta name="twitter:description" content="New York Giants General Manager Dave Gettleman and Assistant General Manager Kevin Abrams addressed the media on Tuesday. Giants cut CB Ryan Lewis."/>
<meta name="twitter:title" content="Dave Gettleman and Kevin Abrams Address the Media; Giants Cut Ryan Lewis"/>
<meta name="twitter:image" content="http://www.bigblueinteractive.com/wp-content/uploads/Dave-Gettleman-New-York-Giants-February-25-2020.jpg"/>
<meta name="twitter:creator" content="@BigBlueInteract"/>
<script type="application/ld+json" class="yoast-schema-graph yoast-schema-graph--main">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"http://www.bigblueinteractive.com/#organization","name":"Big Blue Interactive, LLC","url":"http://www.bigblueinteractive.com/","sameAs":[],"logo":{"@type":"ImageObject","@id":"http://www.bigblueinteractive.com/#logo","url":"http://www.bigblueinteractive.com/wp-content/uploads/2013/07/BBI-Logo.png","width":700,"height":350,"caption":"Big Blue Interactive, LLC"},"image":{"@id":"http://www.bigblueinteractive.com/#logo"}},{"@type":"WebSite","@id":"http://www.bigblueinteractive.com/#website","url":"http://www.bigblueinteractive.com/","name":"Big Blue Interactive","publisher":{"@id":"http://www.bigblueinteractive.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"http://www.bigblueinteractive.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"http://www.bigblueinteractive.com/2021/04/20/dave-gettleman-and-kevin-abrams-address-the-media-giants-cut-ryan-lewis/#primaryimage","url":"http://www.bigblueinteractive.com/wp-content/uploads/Dave-Gettleman-New-York-Giants-February-25-2020.jpg","width":650,"height":434,"caption":"Dave Gettleman, New York Giants (February 25, 2020)"},{"@type":"WebPage","@id":"http://www.bigblueinteractive.com/2021/04/20/dave-gettleman-and-kevin-abrams-address-the-media-giants-cut-ryan-lewis/#webpage","url":"http://www.bigblueinteractive.com/2021/04/20/dave-gettleman-and-kevin-abrams-address-the-media-giants-cut-ryan-lewis/","inLanguage":"en-US","name":"Dave Gettleman and Kevin Abrams Address the Media; Giants Cut Ryan Lewis","isPartOf":{"@id":"http://www.bigblueinteractive.com/#website"},"primaryImageOfPage":{"@id":"http://www.bigblueinteractive.com/2021/04/20/dave-gettleman-and-kevin-abrams-address-the-media-giants-cut-ryan-lewis/#primaryimage"},"datePublished":"2021-04-20T19:59:22+00:00","dateModified":"2021-04-20T19:59:22+00:00","description":"New York Giants General Manager Dave Gettleman and Assistant General Manager Kevin Abrams addressed the media on Tuesday. Giants cut CB Ryan Lewis."},{"@type":"Article","@id":"http://www.bigblueinteractive.com/2021/04/20/dave-gettleman-and-kevin-abrams-address-the-media-giants-cut-ryan-lewis/#article","isPartOf":{"@id":"http://www.bigblueinteractive.com/2021/04/20/dave-gettleman-and-kevin-abrams-address-the-media-giants-cut-ryan-lewis/#webpage"},"author":{"@id":"http://www.bigblueinteractive.com/#/schema/person/7bc6068dd4b7926c9895fe04a8b6a25c"},"headline":"Dave Gettleman and Kevin Abrams Address the Media; Giants Cut Ryan Lewis","datePublished":"2021-04-20T19:59:22+00:00","dateModified":"2021-04-20T19:59:22+00:00","commentCount":0,"mainEntityOfPage":{"@id":"http://www.bigblueinteractive.com/2021/04/20/dave-gettleman-and-kevin-abrams-address-the-media-giants-cut-ryan-lewis/#webpage"},"publisher":{"@id":"http://www.bigblueinteractive.com/#organization"},"image":{"@id":"http://www.bigblueinteractive.com/2021/04/20/dave-gettleman-and-kevin-abrams-address-the-media-giants-cut-ryan-lewis/#primaryimage"},"keywords":"Dave Gettleman,Kevin Abrams,Ryan Lewis,Sandro Platzgummer","articleSection":"News and Notes"},{"@type":["Person"],"@id":"http://www.bigblueinteractive.com/#/schema/person/7bc6068dd4b7926c9895fe04a8b6a25c","name":"Eric Kennedy","image":{"@type":"ImageObject","@id":"http://www.bigblueinteractive.com/#authorlogo","url":"http://2.gravatar.com/avatar/2bf6393a4f959150ea379c639f08d40b?s=96&d=mm&r=g","caption":"Eric Kennedy"},"description":"Eric Kennedy is Editor-in-Chief of BigBlueInteractive.com, a publication of Big Blue Interactive, LLC. Follow @BigBlueInteract on Twitter.","sameAs":["https://www.facebook.com/BigBlueInteract","https://twitter.com/BigBlueInteract"]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel="dns-prefetch" href="//fonts.googleapis.com"/>
<link rel="dns-prefetch" href="//s.w.org"/>
<link rel="alternate" type="application/rss+xml" title="Big Blue Interactive » Feed" href="http://www.bigblueinteractive.com/feed/"/>
<link rel="alternate" type="application/rss+xml" title="Big Blue Interactive » Comments Feed" href="http://www.bigblueinteractive.com/comments/feed/"/>
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.bigblueinteractive.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.4"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel="stylesheet" id="wp-block-library-css" href="http://www.bigblueinteractive.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.4" type="text/css" media="all"/>
<link rel="stylesheet" id="hupso_css-css" href="http://www.bigblueinteractive.com/wp-content/plugins/hupso-share-buttons-for-twitter-facebook-google/style.css?ver=5.2.4" type="text/css" media="all"/>
<link rel="stylesheet" id="social-widget-css" href="http://www.bigblueinteractive.com/wp-content/plugins/social-media-widget/social_widget.css?ver=5.2.4" type="text/css" media="all"/>
<link rel="stylesheet" id="suffusion-google-fonts-css" href="https://fonts.googleapis.com/css?family=Droid+Sans:400,700" type="text/css" media="all" />
<link rel="stylesheet" id="suffusion-theme-css" href="http://www.bigblueinteractive.com/wp-content/themes/suffusion/style.css?ver=4.4.9" type="text/css" media="all"/>
<link rel="stylesheet" id="suffusion-theme-skin-1-css" href="http://www.bigblueinteractive.com/wp-content/themes/suffusion/skins/light-theme-gray-1/skin.css?ver=4.4.9" type="text/css" media="all"/>
<link rel="stylesheet" id="suffusion-child-css" href="http://www.bigblueinteractive.com/wp-content/themes/bbitheme/style.css?ver=4.4.9" type="text/css" media="all"/>
<!--[if !IE]>--><link rel="stylesheet" id="suffusion-rounded-css" href="http://www.bigblueinteractive.com/wp-content/themes/suffusion/rounded-corners.css?ver=4.4.9" type="text/css" media="all"/>
<!--<![endif]-->
<!--[if gt IE 8]><link rel='stylesheet' id='suffusion-rounded-css'  href='http://www.bigblueinteractive.com/wp-content/themes/suffusion/rounded-corners.css?ver=4.4.9' type='text/css' media='all' />
<![endif]-->
<!--[if lt IE 8]><link rel='stylesheet' id='suffusion-ie-css'  href='http://www.bigblueinteractive.com/wp-content/themes/suffusion/ie-fix.css?ver=4.4.9' type='text/css' media='all' />
<![endif]-->
<link rel="stylesheet" id="tablepress-default-css" href="http://www.bigblueinteractive.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.9.2" type="text/css" media="all"/>
<link rel="stylesheet" id="wp-cpl-base-css-css" href="http://www.bigblueinteractive.com/wp-content/plugins/wp-category-posts-list/static/css/wp-cat-list-theme.css?ver=2.0.3" type="text/css" media="all"/>
<link rel="stylesheet" id="wp_cpl_css_0-css" href="http://www.bigblueinteractive.com/wp-content/plugins/wp-category-posts-list/static/css/wp-cat-list-light.css?ver=2.0.3" type="text/css" media="all"/>
<link rel="stylesheet" id="wp_cpl_css_1-css" href="http://www.bigblueinteractive.com/wp-content/plugins/wp-category-posts-list/static/css/wp-cat-list-dark.css?ver=2.0.3" type="text/css" media="all"/>
<link rel="stylesheet" id="wp_cpl_css_2-css" href="http://www.bigblueinteractive.com/wp-content/plugins/wp-category-posts-list/static/css/wp-cat-list-giant-gold-fish.css?ver=2.0.3" type="text/css" media="all"/>
<link rel="stylesheet" id="wp_cpl_css_3-css" href="http://www.bigblueinteractive.com/wp-content/plugins/wp-category-posts-list/static/css/wp-cat-list-adrift-in-dreams.css?ver=2.0.3" type="text/css" media="all"/>
<script type="text/javascript" src="http://www.bigblueinteractive.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp"></script>
<script type="text/javascript" src="http://www.bigblueinteractive.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1"></script>
<script type="text/javascript" src="http://www.bigblueinteractive.com/wp-content/themes/suffusion/scripts/jquery.cycle.all.min.js"></script>
<script type="text/javascript">
/* <![CDATA[ */
var Suffusion_JS = {"wrapper_width_type_page_template_1l_sidebar_php":"fixed","wrapper_max_width_page_template_1l_sidebar_php":"1200","wrapper_min_width_page_template_1l_sidebar_php":"600","wrapper_orig_width_page_template_1l_sidebar_php":"75","wrapper_width_type_page_template_1r_sidebar_php":"fixed","wrapper_max_width_page_template_1r_sidebar_php":"1200","wrapper_min_width_page_template_1r_sidebar_php":"600","wrapper_orig_width_page_template_1r_sidebar_php":"75","wrapper_width_type_page_template_1l1r_sidebar_php":"fixed","wrapper_max_width_page_template_1l1r_sidebar_php":"1200","wrapper_min_width_page_template_1l1r_sidebar_php":"600","wrapper_orig_width_page_template_1l1r_sidebar_php":"75","wrapper_width_type_page_template_2l_sidebars_php":"fixed","wrapper_max_width_page_template_2l_sidebars_php":"1200","wrapper_min_width_page_template_2l_sidebars_php":"600","wrapper_orig_width_page_template_2l_sidebars_php":"75","wrapper_width_type_page_template_2r_sidebars_php":"fixed","wrapper_max_width_page_template_2r_sidebars_php":"1200","wrapper_min_width_page_template_2r_sidebars_php":"600","wrapper_orig_width_page_template_2r_sidebars_php":"75","wrapper_width_type":"fixed","wrapper_max_width":"1200","wrapper_min_width":"600","wrapper_orig_width":"75","wrapper_width_type_page_template_no_sidebars_php":"fixed","wrapper_max_width_page_template_no_sidebars_php":"1200","wrapper_min_width_page_template_no_sidebars_php":"600","wrapper_orig_width_page_template_no_sidebars_php":"75","suf_featured_interval":"6000","suf_featured_transition_speed":"1000","suf_featured_fx":"fade","suf_featured_pause":"Pause","suf_featured_resume":"Resume","suf_featured_sync":"0","suf_featured_pager_style":"numbers","suf_nav_delay":"500","suf_nav_effect":"fade","suf_navt_delay":"500","suf_navt_effect":"fade","suf_jq_masonry_enabled":"disabled","suf_fix_aspect_ratio":"preserve","suf_show_drop_caps":""};
/* ]]> */
</script>
<script type="text/javascript" src="http://www.bigblueinteractive.com/wp-content/themes/suffusion/scripts/suffusion.js?ver=4.4.9"></script>
<link rel="https://api.w.org/" href="http://www.bigblueinteractive.com/wp-json/"/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.bigblueinteractive.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.bigblueinteractive.com/wp-includes/wlwmanifest.xml"/> 
<link rel="shortlink" href="http://www.bigblueinteractive.com/?p=103565"/>
<link rel="alternate" type="application/json+oembed" href="http://www.bigblueinteractive.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.bigblueinteractive.com%2F2021%2F04%2F20%2Fdave-gettleman-and-kevin-abrams-address-the-media-giants-cut-ryan-lewis%2F"/>
<link rel="alternate" type="text/xml+oembed" href="http://www.bigblueinteractive.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.bigblueinteractive.com%2F2021%2F04%2F20%2Fdave-gettleman-and-kevin-abrams-address-the-media-giants-cut-ryan-lewis%2F&amp;format=xml"/>
<!-- Graceful Pull-Quotes plugin v2.6.1 -->
	<link rel="stylesheet" href="http://www.bigblueinteractive.com/wp-content/plugins/graceful-pull-quotes/resources/jspullquotes-core.css" type="text/css"/>
	<link rel="stylesheet" href="http://www.bigblueinteractive.com/wp-content/plugins/graceful-pull-quotes/resources/jspullquotes-default.css" type="text/css"/>
	<script type="text/javascript">
		var jspq_options = new Array("1", "1", "right", "1", "1", "blockquote", "pullquote", "pullquote pqRight");
	</script>
	<script type="text/javascript" src="http://www.bigblueinteractive.com/wp-content/plugins/graceful-pull-quotes/resources/jspullquotes.js"></script>
<!-- end pull-quote additions -->
    <style type="text/css" media="screen">
      div.printfriendly a, div.printfriendly a:link, div.printfriendly a:hover, div.printfriendly a:visited, div.printfriendly a:focus {
        text-decoration: none;
        border: none;
        -webkit-box-shadow:none!important;
        box-shadow:none!important;
      }
    </style>
           <style type="text/css" media="screen">
          div.printfriendly {
            margin: 12px 12px 12px 12px;
          }
          div.printfriendly a, div.printfriendly a:link, div.printfriendly a:visited {
            font-size: 14px;
            color: #6D9F00;
          }
        </style>
		<link rel="stylesheet" href="http://www.bigblueinteractive.com/wp-content/plugins/printfriendly/printfriendly.css" media="screen"/>
        <style type="text/css" media="print">
          .printfriendly {
            display: none;
          }
        </style>
<!-- Begin comScore Tag -->

<script>

  var _comscore = _comscore || [];

  _comscore.push({ c1: "2", c2: "6035223" });

  (function() {

    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;

    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";

    el.parentNode.insertBefore(s, el);

  })();

</script>

<noscript>

  <img src="http://b.scorecardresearch.com/p?c1=2&c2=6035223&cv=2.0&cj=1" />

</noscript>

<!-- End comScore Tag --><script type="text/javascript">
(function() {
var useSSL = 'https:' == document.location.protocol;
var src = (useSSL ? 'https:' : 'http:') +
'//www.googletagservices.com/tag/js/gpt_mobile.js';
document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
})();
</script>
<script type="text/javascript">
googletag.cmd.push(function() {
googletag.enableServices();
googletag.pubads().setTargeting("page_url", "URL");
});
</script><!-- Begin YES header tag -->
<script type="text/javascript">
var section = "Big Blue Interactive";
var ctxPath = "";
var pageid = "index";
var dc_keyVal = "";
</script>

<!-- End YES header tag --><!-- Start DFP SETUP - Header Tags -->
<script type="text/javascript">
      var gptadslots=[], googletag = googletag || {}; googletag.cmd = googletag.cmd || [];
      (function(){ var gads = document.createElement('script');
          gads.async = true; gads.type = 'text/javascript';
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
      })();
</script>
<script type="text/javascript" src="https://img.bnqt.com/lib/js/sdpdfphelper.js"></script>
<script type="text/javascript">
      googletag.cmd.push(function() {
          googletag.pubads().enableAsyncRendering(); googletag.pubads().enableSingleRequest();
          googletag.pubads().setTargeting('title', sdpTargeting.title)
                            .setTargeting('targetPaths', sdpTargeting.targetPaths)
                            .setTargeting('fullPath', sdpTargeting.fullPath)
                            .setTargeting('queryStr', sdpTargeting.queryStr)
                            .setTargeting('domainName', sdpTargeting.domainName);
      });
</script>
<!-- DFP SETUP end --><script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-38817621-1', 'bigblueinteractive.com');
  ga('send', 'pageview');

</script><script language="JavaScript" type="text/JavaScript">
function changePage(newLoc)
 {
   nextPage = newLoc.options[newLoc.selectedIndex].value
		
   if (nextPage != "")
   {
      document.location.href = nextPage
   }
 }
</script><!-- Start Additional Feeds -->
<!-- End Additional Feeds -->
	<!-- CSS styles constructed using option definitions -->
	<style type="text/css">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</style>
		<!-- Custom CSS styles defined in options -->
		<style type="text/css">
			/* <![CDATA[ */
#widgets-above-header .suf-widget{background:#444444;border:none;}
#cred { background:#ffffff;}
aside#text-3{background:#000078;}
div#sidebar {background:#000078;border:none;margin-top:0px;}
#header { padding: 0px; }
div.suf-mag-excerpts-header{font-size:20px;color:#444444;}
h2.suf-mag-headlines-title{font-size:20px;color:#444444;}
div.suf-mag-categories-header{font-size:20px;color:#444444;}
div.suf-mag-excerpt-image{width:200px;float:left;background:#FFFFFF;}
div#sidebar-2 li {list-style:none;margin:0;background:none;}
#nav ul.sf-menu {margin-bottom:1px;}
#nav ul.sf-menu a.with-arrow{padding-left:16px;}

aside#text-226374681 {padding:0;margin:0;text-align:center;}
aside#text-226374681 div.textwidget{padding:0;margin:0;text-align:center;}
.down-ptr {background:none;width:2px;}
div#eazyest-gallery-1{margin-bottom:50px;}

#nav.continuous{position: relative; z-index: 99999; }

h1.blogtitle, h2.blogtitle{
padding: 0px;
margin: 0px;
width: 650px;  
overflow:none;  
}

#header-widgets div.widget_text{
 border:none;
  width:260px;
 padding-left:10px;
 text-align:right; 
  
}

@media (max-width: 649px) {

h1.header {
width: 100%;
height: auto;
}

h2.header {
width: 100%;
height: auto;
}

.blogtitle img {
width: 100%;
height: auto;
}
}

@media  ( max-width :  480px ) {

section.suf-mag-headlines{display:none;}

}			/* ]]> */
		</style>
		<!-- /Custom CSS styles defined in options -->
<!-- location header -->




<script type="text/javascript">var ezouid = "1";</script><base href="http://www.bigblueinteractive.com/2021/04/20/dave-gettleman-and-kevin-abrams-address-the-media-giants-cut-ryan-lewis/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 124135;
var ezdomain = 'bigblueinteractive.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":124135,"domain_test_group":20210306,"engaged_time_visit":0,"ezcache_level":2,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"adf3379f-7a0e-426a-5c48-ba5b44a75b64","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":131054,"response_time_orig":8,"serverid":"3.236.88.159:13792","state":"VA","t_epoch":1618966078,"template_id":126,"time_on_site_visit":0,"url":"http://www.bigblueinteractive.com/2021/04/20/dave-gettleman-and-kevin-abrams-address-the-media-giants-cut-ryan-lewis/","user_id":0,"word_count":5017,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_124135=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["adf3379f-7a0e-426a-5c48-ba5b44a75b64", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>

<body class="post-template-default single single-post postid-103565 single-format-standard light-theme-gray-1 suffusion-custom preset-custom-componentspx device-desktop">

    			<!-- #widgets-above-header -->
	<div id="widgets-above-header" class="warea fix">
		<div class="col-control">
<!-- widget start --><div id="custom_html-3" class="widget_text widget_custom_html suf-widget suf-widget-1c"><div class="textwidget custom-html-widget"><!-- SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.main -->
<div id="usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.main">
     <script type="text/javascript">
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/728x90_1a/sports/football/nfl.main', [728,90], 'usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.main').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_728x90_1a_sports_football_nfl.main');
         });
     </script>
</div>
</div></div><!-- widget end -->		</div>
	</div>
	<!-- /#widgets-above-header -->
		<div id="wrapper" class="fix">
					<div id="header-container" class="custom-header fix">
					<header id="header" class="fix">
			<h2 class="blogtitle left"><a href="http://www.bigblueinteractive.com"><img src="http://bigblueinteractive.com/images/header-image-700.gif" alt="Big Blue Interactive"/></a></h2>
		<div class="description hidden">The Latest News, Analysis and Discussion of the New York Football Giants</div>
    </header><!-- /header -->
	<!-- #header-widgets -->
	<div id="header-widgets" class="warea">
<!-- widget start --><div id="text-533808691" class="widget_text suf-widget suf-widget-1c">			<div class="textwidget"> </div>
		</div><!-- widget end -->	</div>
	<!-- /#header-widgets -->
 	<nav id="nav" class="continuous fix">
		<div class="col-control left">
<ul class="sf-menu">
<li id="menu-item-33111" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-33111 dd-tab"><a href="http://www.bigblueinteractive.com">Home</a>
<ul class="sub-menu">
	<li id="menu-item-33113" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33113"><a href="http://www.bigblueinteractive.com/information-pages/terms-of-use/">Terms Of Use</a></li>
	<li id="menu-item-33114" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33114"><a href="http://www.bigblueinteractive.com/information-pages/code-of-conduct/">Code Of Conduct</a></li>
	<li id="menu-item-33115" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33115"><a href="http://www.bigblueinteractive.com/information-pages/privacy-policy/">Privacy Policy</a></li>
	<li id="menu-item-33116" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33116"><a href="http://www.bigblueinteractive.com/information-pages/frequently-asked-questions-faq/">FAQ</a></li>
	<li id="menu-item-33117" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33117"><a href="http://www.bigblueinteractive.com/information-pages/about-us/">About Us</a></li>
	<li id="menu-item-72147" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72147"><a href="http://www.bigblueinteractive.com/information-pages/contact-us/">Contact Us</a></li>
</ul>
</li>
<li id="menu-item-33112" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-33112 dd-tab"><a href="http://corner.bigblueinteractive.com/index.php">Corner Forum</a>
<ul class="sub-menu">
	<li id="menu-item-33119" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33119"><a href="http://corner.bigblueinteractive.com/index.php?show=1">All Threads</a></li>
	<li id="menu-item-33120" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33120"><a href="http://corner.bigblueinteractive.com/index.php?show=2">Football Threads</a></li>
	<li id="menu-item-33121" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33121"><a href="http://corner.bigblueinteractive.com/index.php?show=3">Non-Football Threads</a></li>
	<li id="menu-item-33122" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33122"><a href="http://corner.bigblueinteractive.com/index.php?show=5">Forum Archives</a></li>
</ul>
</li>
<li id="menu-item-35092" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-35092 dd-tab"><a href="#">Gameday</a>
<ul class="sub-menu">
	<li id="menu-item-35093" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35093"><a href="http://www.bigblueinteractive.com/new-york-giants-schedule/">Schedule</a></li>
	<li id="menu-item-35094" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35094"><a href="http://www.bigblueinteractive.com/new-york-giants-game-previews-reviews/">BBI Game Previews and Reviews</a></li>
	<li id="menu-item-35096" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35096"><a target="_blank" rel="noopener noreferrer" href="http://www.nfl.com/standings">Standings (NFL.com)</a></li>
	<li id="menu-item-35097" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-35097"><a target="_blank" rel="noopener noreferrer" href="https://www.giants.com/team/stats/">Statistics (Giants.com)</a></li>
	<li id="menu-item-35095" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35095"><a href="http://www.bigblueinteractive.com/new-york-giants-historical-statistics/">Historical Statistics</a></li>
</ul>
</li>
<li id="menu-item-33118" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-33118 dd-tab"><a href="http://www.bigblueinteractive.com">Team</a>
<ul class="sub-menu">
	<li id="menu-item-33123" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33123"><a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-roster/">Roster</a></li>
	<li id="menu-item-33124" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33124"><a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-depth-chart/">Depth Chart</a></li>
	<li id="menu-item-33125" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33125"><a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-scouting-reports/">Scouting Reports</a></li>
	<li id="menu-item-33126" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33126"><a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-transactions/">Transactions</a></li>
	<li id="menu-item-33127" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33127"><a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-player-salaries/">Player Salaries</a></li>
</ul>
</li>
<li id="menu-item-35103" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-35103 dd-tab"><a href="#">Team Building</a>
<ul class="sub-menu">
	<li id="menu-item-35104" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35104"><a href="http://www.bigblueinteractive.com/free-agency/">Free Agency</a></li>
	<li id="menu-item-35105" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35105"><a href="http://www.bigblueinteractive.com/new-york-giants-nfl-draft/">NFL Draft</a></li>
	<li id="menu-item-35106" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35106"><a href="http://www.bigblueinteractive.com/new-york-giants-training-camp/">Training Camp</a></li>
</ul>
</li>
<li id="menu-item-33128" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-33128 dd-tab"><a href="http://www.bigblueinteractive.com/information-pages/annual-records-and-team-accolades/">Giants Info &amp; History</a>
<ul class="sub-menu">
	<li id="menu-item-33130" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33130"><a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-contact-information/">Contact Info</a></li>
	<li id="menu-item-33131" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33131"><a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-team-administration/">Administration</a></li>
	<li id="menu-item-33132" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33132"><a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-staff/">Coaching Staff</a></li>
	<li id="menu-item-33133" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33133"><a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-coaching-history/">Coaching History</a></li>
	<li id="menu-item-33134" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33134"><a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-annual-records/">Annual Records</a></li>
	<li id="menu-item-33135" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33135"><a href="http://www.bigblueinteractive.com/information-pages/hall-of-fame-new-york-giants/">Hall Of Fame</a></li>
	<li id="menu-item-33136" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33136"><a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-retired-jersey-numbers/">Retired Jerseys</a></li>
	<li id="menu-item-33137" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33137"><a href="http://www.bigblueinteractive.com/information-pages/new-york-giants-ring-of-honor/">Ring Of Honor</a></li>
</ul>
</li>
<li id="menu-item-35102" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-35102 dd-tab"><a href="#">Info/Links</a>
<ul class="sub-menu">
	<li id="menu-item-35107" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35107"><a href="http://www.bigblueinteractive.com/new-york-giants-important-dates/">Important Dates</a></li>
	<li id="menu-item-48512" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48512"><a href="http://www.bigblueinteractive.com/information-pages/bigblueinteractivecom-player-of-the-year-award-winners/">Giant of the Year Award</a></li>
	<li id="menu-item-35108" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35108"><a href="http://www.bigblueinteractive.com/new-york-giants-articles/">Articles</a></li>
	<li id="menu-item-35109" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35109"><a href="http://www.bigblueinteractive.com/glossary/">Glossary</a></li>
	<li id="menu-item-35110" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35110"><a href="http://www.bigblueinteractive.com/links/">Links</a></li>
</ul>
</li>
<li id="menu-item-33129" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-33129 dd-tab"><a href="http://astore.amazon.com/bigblueintera-20">BBI Shop</a>
<ul class="sub-menu">
	<li id="menu-item-33140" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-33140"><a href="https://www.amazon.com/?_encoding=UTF8&amp;camp=1789&amp;creative=9325&amp;linkCode=ur2&amp;tag=bigblueintera-20">Amazon.com</a></li>
</ul>
</li>

</ul>
		</div><!-- /col-control -->
	</nav><!-- /nav -->
			</div><!-- //#header-container -->
		

<!-- Feb 2019  Launchpad goes below here -->

<!-- SMG_BigBlueInteractive/launchpad/sports/football/nfl.main -->
<div id="usmg_ad_SMG_BigBlueInteractive_launchpad_sports_football_nfl.main">
     <script type="text/javascript">
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/launchpad/sports/football/nfl.main', [[970,66],[970,250]], 'usmg_ad_SMG_BigBlueInteractive_launchpad_sports_football_nfl.main').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_launchpad_sports_football_nfl.main');
         });
     </script>
</div>



	
			<div id="container" class="fix">
				    <div id="main-col">
		  	<div id="content">
<!-- SiteCatalyst code version: G.5. Copyright 1997-2003 Omniture, Inc. More info available at http://www.omniture.com -->
<div style="position:absolute; top:-100px; left:-100px; width:100px;">
<script type="text/javascript" src="/MLBAM_tracking.js"></script>
</div>
<!-- End SiteCatalyst code version: G.5. -->	<article class="post-103565 post type-post status-publish format-standard has-post-thumbnail hentry category-news-and-notes tag-david-gettleman tag-kevin-abrams tag-ryan-lewis tag-sandro-platzgummer category-3-id full-content meta-position-corners fix" id="post-103565">


<!-- SMG_BigBlueInteractive/outstream/sports/football/nfl.general -->


<script>!function(e,t,a,n,g){e[n]=e[n]||[],e[n].push({"gtm.start":(new Date).getTime(),event:"gtm.js"});var m=t.getElementsByTagName(a)[0],r=t.createElement(a);r.async=!0,r.src="https://www.googletagmanager.com/gtm.js?id=GTM-PL4PD49",m.parentNode.insertBefore(r,m)}(window.parent,window.parent.document,"script","dataLayer");</script><script>var iframe=window.parent.document.createElement("iframe");iframe.src="https://www.googletagmanager.com/ns.html?id=GTM-PL4PD49";iframe.height="0";iframe.width="0";iframe.style="display:none;visibility:hidden";window.parent.document.body.appendChild(iframe);</script><script>window.parent['$$mm-analytics'] = window.parent['$$mm-analytics'] || {};if (typeof window.parent['$$mm-analytics'].firstEmbed === 'undefined') {window.parent['$$mm-analytics'].firstEmbed = Date.now();}</script><script async="" type="text/javascript" src="https://bucket1.mm-syringe.com/prod/configs/0ed7b503-aa2d-46c4-85ad-88669fa21b92.js"></script><script async="" type="text/javascript" src="https://bucket1.mm-syringe.com/prod/injector/injector.1.5.3.js"></script>


<header class="post-header title-container fix">
	<div class="title">
		<h1 class="posttitle"><a href="http://www.bigblueinteractive.com/2021/04/20/dave-gettleman-and-kevin-abrams-address-the-media-giants-cut-ryan-lewis/" class="entry-title" rel="bookmark" title="Dave Gettleman and Kevin Abrams Address the Media; Giants Cut Ryan Lewis">Dave Gettleman and Kevin Abrams Address the Media; Giants Cut Ryan Lewis</a></h1>
		<div class="postdata fix">
		<span class="author"><span class="icon"> </span>Posted by <span class="vcard"><a href="http://www.bigblueinteractive.com/author/eric-kennedy/" class="url fn" rel="author">Eric Kennedy</a></span></span>	</div><!-- /.postdata -->
		</div><!-- /.title -->
		<div class="date"><span class="month">Apr</span> <span class="day">20</span><span class="year">2021</span></div>
	</header><!-- /.title-container -->
	<span class="post-format-icon"> </span><span class="updated" title="2021-04-20T15:59:22-04:00"></span>		<div class="entry-container fix">
			<div class="entry fix">
<!-- Start USAT June 2018 Code  -->

<div class="ctcg_68715" style="width:1px;height:1px"></div>
<script>(function(doc){

                                var gec = function(c){return doc.getElementsByClassName ? doc.getElementsByClassName(c) : doc.querySelectorAll("."+c);}

                                var tpc = "[ENTER_CLICK_URL_UNESCAPED]",

                                                tpi = "[ENTER_IMPRESSION_URL_UNESCAPED]",

                                                ch = "",

                                                p = location.protocol === "https:" ? "https:" : "http:", s = doc.createElement("script"),

                                                idx = gec("ct_invocation_68715").length,c = gec("ctcg_68715");

                                s.className="ct_invocation_68715 ct_invocation_68715_"+idx;

                                if (c&&c[0]) c[0].className = "ctcg_68715_" + idx;

                                s.setAttribute("tpc",tpc);s.setAttribute("tpi",tpi);s.setAttribute("ch", ch);

                                s.src = p+"//invocation.combotag.com/placement_invocation?id=68715&idx="+idx;

                                doc.getElementsByTagName("head")[0].appendChild(s);

                })(document);

</script>


<!-- End USAT June 2018 Code  --><div class="pf-content"><div style="padding-bottom:20px; padding-top:10px;" class="hupso-share-buttons"><!-- Hupso Share Buttons - http://www.hupso.com/share/ --><a class="hupso_counters" href="http://www.hupso.com/share/"><img src="https://static.hupso.com/share/buttons/share-small.png" style="border:0px; padding-top:2px; float:left;" alt="Share Button" /></a><script type="text/javascript">var hupso_services_c=new Array("twitter","facebook_like","facebook_send","google","pinterest");var hupso_twitter_via = "bigblueinteract";var hupso_counters_lang = "en_US";var hupso_image_folder_url = "";var hupso_twitter_via="bigblueinteract";var hupso_url_c="";var hupso_title_c="Dave Gettleman and Kevin Abrams Address the Media; Giants Cut Ryan Lewis";</script><script type="text/javascript" src="https://static.hupso.com/share/js/counters.js"></script><!-- Hupso Share Buttons --></div><div id="attachment_98084" style="width: 660px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-98084" src="http://www.bigblueinteractive.com/wp-content/uploads/Dave-Gettleman-New-York-Giants-February-25-2020.jpg" alt="Dave Gettleman, New York Giants (February 25, 2020)" width="650" height="434" class="size-full wp-image-98084" srcset="http://www.bigblueinteractive.com/wp-content/uploads/Dave-Gettleman-New-York-Giants-February-25-2020.jpg 650w, http://www.bigblueinteractive.com/wp-content/uploads/Dave-Gettleman-New-York-Giants-February-25-2020-300x200.jpg 300w, http://www.bigblueinteractive.com/wp-content/uploads/Dave-Gettleman-New-York-Giants-February-25-2020-150x100.jpg 150w" sizes="(max-width: 650px) 100vw, 650px"/><p id="caption-attachment-98084" class="wp-caption-text">Dave Gettleman – © USA TODAY Sports</p></div>
<p><strong>DAVE GETTLEMAN AND KEVIN ABRAMS ADDRESS THE MEDIA…</strong><br/>
New York Giants General Manager Dave Gettleman and Assistant General Manager Kevin Abrams addressed the media on Tuesday (<a href="https://www.giants.com/video/gm-dave-gettleman-asst-gm-kevin-abrams-recap-offseason-moves" target="_blank" rel="noopener noreferrer"><strong>video</strong></a>):</p>
<p>Gettleman: Good afternoon, everybody. Good to see you, I’m looking at little tiny screens. Trust you’re all well. Kevin and I are here to talk about free agency and then on Thursday I’m going to be with [Director of Pro Scouting] Chris Pettit and we’ll talk about the upcoming college draft. Let’s go.</p>
<p>Q: Dave, you’ve always kind of avoided guys with injury histories it seems like in free agency, you’ve spoken about that. What’s different this year with guys like [Wide Receiver] Kenny [Golladay] and [Cornerback] Adoree’ [Jackson] who have some injury histories in their past and you felt comfortable paying them big money?</p>
<p>Gettleman: I tell you what, we had them come in. It was a little different with free agency this year, we actually had them come in first, so we really – all three guys, Kenny, Adoree’ and [Tight End] Kyle [Rudolph] – we had them in here and it was an old school free agency. We got to talk, a chance to visit with them, they went out to dinner with various people in the organization, they were here a couple of nights, our doctors were able to put their hands on them. It was an old-fashioned free agency. [Head Athletic Trainer] Ronnie [Barnes] and Head Team Physician] Doctor [Scott] Rodeo felt very comfortable with us moving with the signing of those three guys.</p>
<p>Q: What are your expectations for the cap next year and how much did an expected increase play into how aggressive you guys were this year?</p>
<p>Abrams: Well, we don’t know what next year is going to look like yet, so we’re making some conservative assumptions. We were aggressive this year, we had to do probably a few practices that we normally, typically try to avoid, but with a lower cap number and some plans to be aggressive we had to do some of those things. We know that next year’s number could be a low one again and we’re prepared for whatever the outcome is.</p>
<p>Q: Kevin, at the start of this, I mean you know the budget and the numbers better than anybody going into this process probably to the penny I would guess or certainly to the pennies. If I would have taken you back to the start of free agency and said, ‘I’m pretty confident you guys are going to get the top receiver Kenny Golladay for big money and perhaps the top cornerback for big money,’ would you have been surprised, not surprised, or not so sure you’d be able to do that with the cap?</p>
<p>Abrams: There were no surprises. I mean, it’s always a bit of an unknown who the players are that you’ll be able to target and who you’ll be able to attract, but we knew we were going to be aggressive.</p>
<p>Q: And as far as being aggressive, you can’t be aggressive unless there’s money to do that obviously. There’s this whole, the Giants went into this with however many millions in the cap and you knew you could manipulate it some way, shape or form. Did you know that you could give 100 million dollars in salaries or guarantees to just a couple of players? Did you know beforehand that was possible?</p>
<p>Abrams: We did, yes.</p>
<p>Q: Dave, when you go into free agency, how much does what you do in free agency reflect on the draft? I mean, do you evaluate all of the college players and say, ‘We need to fill holes. We need to do this in free agency?’</p>
<p>Gettleman: What we do is we have this space we call our Football Ops Center. By the time we get deep into free agency conversations, we’ve had our February draft readings. So in our Ops Center, we have our draft on one board and our unrestricted free agency board on the other. And what we do is we actually do it by color, we take a look at the positions and see where if I need a kicker, is it heavy in free agency or am I going to have to go to the draft? So we marry up both, to answer your question, and then we just move forward and make decisions on which way we’re going to go because maybe free agency is thick with a position and the draft isn’t or vice-versa. So we do marry it up.</p>
<p>Q: Kevin, we all like to think that we’re experts in what a guy is worth, but you’re an expert in the building at negotiating these contracts. Do you believe that you can overpay for a player? Is there such a thing? Is it a more complicated equation than just saying a player is worth a certain amount in the current market or in the market of this position? How do you evaluate that?</p>
<p>Abrams: I mean, certainly you can overpay a player. In free agency, the danger of free agency is that it’s more auction than it is negotiation, but we know what we think the market is for a position and we know where we think players fit into that market and we’ll set those parameters of where we’re willing to go to get a player well in advance of free agency. Ideally, you come in lower obviously than what you think your ceiling of comfort is, but we do identify what those parameters are before we even begin the process.</p>
<p>Q: Dave, a question about [Running Back Devontae] Booker, you guys were pretty aggressive right out of the gate about going after him for some depth at running back. Did you go after him so aggressively because you believe – like, say if hypothetically [Running Back] Saquon [Barkley] were not on the field for some reason, knock on wood, do you feel confident that Booker would be able to handle that position and the workload and is that why you prioritized him as a player?</p>
<p>Gettleman: Well, one of the reasons we prioritized Devontae is you can never have too many good players at any position, I don’t care what anybody says. One of the things that made Devontae so attractive was the fact that we felt he was a legitimate three-down running back. It’s always a group decision here, everything’s in the best interest of the Giants, so obviously he can be a good part of our solution at running back.</p>
<p>Q: Hey Dave and Kevin, in terms of the league, there was so much talk about the cap going down and that there would be a depressed market and that teams would look for value under market. I’m curious if you guys identified a situation where you could be aggressive, kind of go counter to what maybe the league was expecting to do and maybe that’s how some of your deals with Golladay and then obviously Adoree’, which came up later, was kind of a counter-thinking when the market is supposed to be as depressed as a lot of people thought it would be.</p>
<p>Abrams: I think that was a small part of our thought process. I mean, we identified, like everyone had, that this year was going to be a little different – cap going down impacts everybody and so I think we thought that there would be some opportunities because there might be fewer buyers out there. Our plan was to be aggressive from the beginning though and we knew that we had ownership support, which was probably uncommon this year to be as aggressive as we were. And we had our targets and as the market played out it became apparent to us that of the targets that we wanted to go and pursue who was going to be available at the right price for us.</p>
<p>Gettleman: Just to supplement that, we feel like we got three or four, really – have to count [DL] Leonard [Williams], spent money on him – we got four high-dollar guys at very good value for their positions, for the whole nine yards. We feel very good about what we’ve done.</p>
<p>Q: Kyle Rudolph, obviously, it seemed like from the reporting that he agreed to a contract, then he came in for a physical and some stuff came up. Seemed like a kind of point where you guys might have had some leverage to make his contact more incentive-based or make him earn it or lower the guarantees. From an organizational standpoint, why stick with the original handshake agreement there?</p>
<p>Abrams: Once he went through all the medical evaluations, we didn’t think that it was necessary.</p>
<p>Gettleman: We are the Giants, we’re going to do everything with class. We had an agreement, Ronnie signed off on it, Doc Rodeo signed off on it, so we were fine.</p>
<p>Q: Dave, you mentioned the Leonard Williams contract. How tough was that negotiation relatively? Kevin, there was a report that you actually stepped in there at the eleventh hour. If you could discuss your role.</p>
<p>Abrams: It was a good negotiation. The agents were very good to work with, they were interactive, which isn’t always the case as players get closer and closer to free agency. Sometimes they become a little harder to reach as they get closer to free agency, but these guys remained involved. Leonard clearly wanted to be here and we clearly wanted him here. It took a while to establish what was a fair spot within the market from both perspectives, but eventually we got there.</p>
<p>Gettleman: Just to be clear, Kevin’s the negotiator here. What we all do is we all sit down and say, ‘Okay, Ryan Dunleavy is our wide receiver. We like his talents and we like his skill. What’s Ryan’s value compared to the rest of the league, the rest of the wide receivers that are out there? What wide receivers got paid in the past year or so?’ because you don’t want to go back three years or so because deals are old. It’s a group effort with Kevin doing the negotiating. It’s about value and being comfortable with the end result, which we were very comfortable with the end results.</p>
<p>Q: Hey Dave, when you look at the moves you’ve made so far and the ones you’ll continue to make obviously with the draft upcoming and even beyond that, how much of it is designed to make sure [Quarterback] Daniel Jones has every opportunity to be the quarterback you’ve always believed he can be?</p>
<p>Gettleman: You know, my job is to put everybody in a position where they’re successful, plain and simple, that’s my job, both on the field and off the field. Of course, I’ve always believed that you draft the guy that you feel is going to be your franchise quarterback, first thing you’ve got to do is get people around him to keep him upright and then you’ve got to get him playmakers. You help him by doing a variety of things. Obviously, when we make moves on the offensive side and the defensive side – because I’ve said to you folks before, offense scores points, defense wins championships – so the point is every move you make is obviously to help each side of the ball, and again special teams are critical as well. So, everything is made with a broad view of how we’re going to put the finishing touches on this and make it right. Obviously, we felt like we’d like to get a bigger wide receiver, Kenny was available, we make the deal that’s obviously going to help Daniel. Kyle Rudolph is a professional tight end, he’s been in the league ten years, he knows all the ins and outs, he’s still a good player, of course that helps Daniel, but it also helps our running game too and it helps Saquon.</p>
<p>Q: Kevin, for you, at what point will, or perhaps already has the idea entered your mind about Saquon’s extension and obviously a little bit beyond that you hope to be extending Daniel because you hope that he plays great in the meantime, obviously?</p>
<p>Abrams: Those will be collective decisions. Ownership will be involved, obviously Dave will lead the charge and when the time is right, we’ll attack those two.</p>
<p>Q: With everything that you did this year, was whatever in your mind (regarding player extensions) as you spent this year?</p>
<p>Abrams: Always. Everything we do has an immediate and a one-, two-, three-year horizon and we’re always mindful of how things impact both us today and how it impacts us next year and beyond, so we’re very cognizant of all of those variables.</p>
<p>Gettleman: I think the best way I can say it is really you can’t do anything in a vacuum. It’s all going to be interconnected and interrelated, and that’s how we operate.</p>
<p>Q: I know there were reports that you were interested in [Rams Outside Linebacker] Leonard Floyd. He obviously ended up going back to the Rams. I’m just curious, how you feel about your edge rusher group that you have right now?</p>
<p>Gettleman: Listen, [LB] Lorenzo [Carter] and [LB Oshane Ximines] are rehabbing, they’re coming along well, I feel good about those two guys. You feel good about [LB] Cam Brown getting better, [LB] Carter Coughlin’s going to be better. You’re growing them up and then you’re looking at the draft as well. You’re always looking to get better. Like I said, you can never have too many good players at one position, so you’re always going to look to improve. Those guys, I wish that Lorenzo and X had been able to play the whole season last year, but you know what, they couldn’t, so we filled in with some guys and did the best we could. We’re going to do better.</p>
<p>Q: Dave, just to build off that for one second. He asked about the edge group. [Defensive End Ifeadi] Odenigbo that you signed, you didn’t mention him. Is he part of that group? I’m just wondering where you guys kind of view him.</p>
<p>Gettleman: Believe it or not, he’s got some inside pass rush to him. He’s got some inside, sub pass rush to him. They’re all part of the group, they’re all part of the group.</p>
<p>Q: I was just curious if you viewed him as an outside linebacker or if you viewed him as a defensive end in a 3-4 more as a primary.</p>
<p>Gettleman: He’ll play outside and he’ll also do some sub, inside sub pass rush stuff.</p>
<p>Q: Dave, you mentioned the whole bringing Kenny in and the guys in for a visit. With Kenny in particular, what was it you needed answered and part of the reason you guys brought him in?</p>
<p>Gettleman: Well, you bring him in because you want to get a physical on him. That was the biggest reason, get a physical on him. But it was nice for a change to get to know a guy and have that opportunity to do that. Like I said, it was like the old days. The biggest reason was the physical.</p>
<p>Abrams: It wasn’t just our decision, the players wanted to come in as well. Both parties wanted to have the visit.</p>
<p>Q: Kevin, you mentioned also that you had to do some things that normally you don’t do in regards to contracts and money, future money down the line, void years and that kind of stuff. How would you categorize where you stand financially moving forward for the future, for the next year or two let’s say?</p>
<p>Abrams: I think 2022 could be a little bit of a challenge depending on where the cap goes to. Beyond, I’m more optimistic that nothing that we’ve done last year or this year puts us in any kind of precarious position. Next year could be a little bit of a challenge, we’ll see. It’s going to depend on science and state legislatures and fans in stands and a lot of other variables and we’ll see where it goes. I don’t think we’re in a bad spot cap-wise, but next year could be a little more challenging than probably the years after that.</p>
<p>Q: Dave, we always talk about weapons, you always tease us about it and you got a nice one in Kenny Golladay. Do you feel you have a solid arsenal right now for this year? We’re talking weapons again, Dave.</p>
<p>Gettleman: You know, yes. To answer your question, we’re better, and the other guy that’s going to be interesting is [WR] John Ross when he walks in the door because he gives you the take-off-the-top, oh my gosh speed. Yes, again, you want touchdown-makers, it’s what you’re looking for on offense and we feel like we added them.</p>
<p>Q: Kevin, how do you balance free agency with the draft in terms of filling needs, but at the same time selecting the best available talent? It seems to be a delicate and challenging combination.</p>
<p>Abrams: As Dave mentioned before, we begin the offseason identifying where we feel like we have needs. Free agency comes first, so we’ll set that board up, find where the value is, where the consensus is between our personnel people and our coaching staff, identify the targets we think best fit the Giants, and then we’ll incorporate what the early view of our draft board looks like and understand where are our needs and our fits in free agency that also are redundant with where the draft is strong and vice-versa. Where the draft is weak, that might be a difference-maker when deciding between who to approach in free agency.</p>
<p>Q: Dave, just going back to Leonard Williams really quick, what was the calculus between resigning Leonard and possibly bringing back [Vikings Defensive Tackle] Dalvin Tomlinson. In hindsight, was there any regret with how you guys handled Tomlinson over the last year, be it maybe not resigning him early or trading him when you might have had the chance to?</p>
<p>Gettleman: Dalvin is a wonderful young man and he was a captain, so obviously there’s regret. But at the end of the day, you only have so much money and you’ve got to make decisions, that’s just the way it is. We’ll miss Dalvin and I’m thrilled that he got what he wanted and Minnesota is a fine organization, so for what it’s worth, sure it’s hard, but unfortunately because of what happened you have to make decisions.</p>
<p>Q: As far as Leonard goes, what kind of separated him and made him a priority to try and bring back and ultimately resign at that number?</p>
<p>Gettleman: Well, maybe 11.5 sacks, maybe that was part of it. You know, he’s very versatile, he’s a legitimate inside pass rusher and he really blossomed. He loves being here and we love having him, so that was part of the decision.</p>
<p>Q: We count the hundreds of millions of dollars that were spent and the number of people who are coming in. How do you guys quantify how much better this team has gotten in your mind, how much closer you are to the team you think can contend in the last six weeks? Do you feel like you’ve made large strides? Do you feel like you’ve made small strides? Is it more of an immediate impact that you’re looking for?</p>
<p>Abrams: From my opinion, and I think Dave would agree, I think our roster is a lot better now than it was at the end of the season and the offseason is not over yet, so we’ll still have more opportunities to add players. So I think we feel good with what we’ve done. I think we’re a deeper, more talented team. Hope that answers the question.</p>
<p>Gettleman: You know, you can’t quantify it. It’s not going to be quantified until the fall and we start playing in September. But we feel very good about what we’ve done, we feel very good about the direction the team is taking with getting Kenny signed and Kyle Rudolph and Devontae Booker and Adoree’ Jackson and Leo. We feel really great about that and we really feel we’re building a solid football team that the fans can be proud of.</p>
<p>Q: Hey Dave, regarding the Adoree’ Jackson deal, Mike Sando from the Athletic talked to a few of your colleagues, executive-wise, around the league and a few of them were very critical of the contract. They said it was inexcusable, high potential for disaster, so a couple of those guys around the league kind of hammered you on that deal. What is your reaction to that and why do you think Adoree’ is worth that when you look at him skill-wise and injury-wise?</p>
<p>Gettleman: Well, my reaction to that is one of the things that makes America a great place is everyone is entitled to an opinion. Time will tell.</p>
<p>Q: What do you think of him as a player and why did you think he was worth that money when you looked at him? Obviously, you guys felt like he was worth the money. Why is that when you look at him?</p>
<p>Gettleman: Why was that? He’s got inside-outside flex, he’s a legitimate cover guy, he can run and he’s a very smart football player and he’s got ball skills. All of that stuff made him worth that.</p>
<p><strong>GIANTS CUT RYAN LEWIS…</strong><br/>
The New York Giants have officially waived cornerback Ryan Lewis, who was originally signed by the Arizona Cardinals as an undrafted rookie free agent after the 2017 NFL Draft. He has spent time with the Cardinals (2017), New England Patriots (2017-2018), Buffalo Bills (2018), Indianapolis Colts (2019), Philadelphia Eagles (2019), Miami Dolphins (2019), and Washington Football Team (2020). The Giants signed Lewis to the Practice Squad in early September 2020 and to the 53-man roster two weeks later. He played in five games for the Giants, starting three (25 percent of defensive snaps). Lewis finished the year with 13 tackles and one pass defense. The Giants placed Lewis on Injured Reserve in early November 2020 with a hamstring injury.</p>
<p><strong>GIANTS RE-SIGN SANDRO PLATZGUMMER…</strong><br/>
The Giants have re-signed running back Sandro Platzgummer, who w<span>as allocated to the team in April 2020 as part of the NFL’s International Player Pathway Program. As part of that program, Platzgummer was</span><span> allowed him to remain on the Giants’ Practice Squad last season without counting towards the Practice Squad limit. Platzgummer played for the Swarco Raiders Tirol of the Austrian Football League.</span></p>
<div class="printfriendly pf-alignright"><a href="#" style="outline:none;" rel="nofollow" onclick="window.print(); return false;" class="noslimstat" title="Printer Friendly, PDF &amp; Email"><img style="border:none;-webkit-box-shadow:none; box-shadow:none;" src="https://cdn.printfriendly.com/buttons/print-button-nobg.png" alt="Print Friendly, PDF &amp; Email"/></a></div></div>			</div><!--/entry -->

		</div><!-- .entry-container -->
<div class="author-info fix">
<h4>Eric Kennedy</h4>
<img alt="" src="https://2.gravatar.com/avatar/2bf6393a4f959150ea379c639f08d40b?s=64&amp;d=mm&amp;r=g" srcset="http://2.gravatar.com/avatar/2bf6393a4f959150ea379c639f08d40b?s=128&amp;d=mm&amp;r=g 2x" class="avatar avatar-64 photo" height="64" width="64" />Eric Kennedy is Editor-in-Chief of BigBlueInteractive.com, a publication of Big Blue Interactive, LLC. Follow @BigBlueInteract on Twitter.</div>
<footer class="post-footer postdata fix">
		<span class="category"><span class="icon"> </span><a href="http://www.bigblueinteractive.com/category/news-and-notes/" rel="category tag">News and Notes</a></span>
		<span class="tags tax"><span class="icon"> </span>Tagged with: <a href="http://www.bigblueinteractive.com/tag/david-gettleman/" rel="tag">Dave Gettleman</a>, <a href="http://www.bigblueinteractive.com/tag/kevin-abrams/" rel="tag">Kevin Abrams</a>, <a href="http://www.bigblueinteractive.com/tag/ryan-lewis/" rel="tag">Ryan Lewis</a>, <a href="http://www.bigblueinteractive.com/tag/sandro-platzgummer/" rel="tag">Sandro Platzgummer</a></span>
	</footer><!-- .post-footer -->
<section id="comments">
<p>Sorry, the comment form is closed at this time.</p></section>   <!-- #comments -->	
	</article>
	
	<!--/post -->
<nav class="post-nav fix">
<table>
<tbody><tr>
	<td class="previous"><a href="http://www.bigblueinteractive.com/2021/04/08/giants-officially-hire-three-new-quality-control-coaches/" rel="prev"><span class="icon"> </span> Giants Officially Hire Three New Quality Control Coaches</a></td>
	<td class="next"></td>
</tr>
</tbody></table>
</nav>
      </div><!-- content -->
    </div><!-- main col -->
<div id="sidebar-wrap" class="sidebar-wrap sidebar-wrap-right fix">		<!-- #wsidebar-top -->
		<div id="wsidebar-top" class="dbx-group right boxed warea">
<!--widget start --><aside id="custom_html-2" class="widget_text dbx-box suf-widget widget_custom_html"><div class="widget_text dbx-content"><div class="textwidget custom-html-widget"><!-- SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.main -->
<div id="usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.main">
     <script type="text/javascript">
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/300x250_1a/sports/football/nfl.main', [[300,250],[300,600]], 'usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.main').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_300x250_1a_sports_football_nfl.main');
         });
     </script>
</div>



</div></div></aside><!--widget end --><!--widget start --><aside id="wp_category_post_list_itg-2" class="dbx-box suf-widget widget_wp_category_post_list_itg"><div class="dbx-content"><h3 class="dbx-handle plain"><a href="http://www.bigblueinteractive.com/category/cornerposts/">Corner Forum Highlights</a></h3><ul class="wp-cpl-widget wp-cpl-theme-0"><li class="wp-cpl wp-cpl-even"><a href="https://corner.bigblueinteractive.com/index.php?mode=2&amp;thread=608146#new_tab" title="Permalink to: Forum Post: Asshat rumor regarding Evan Engram and Kyle Pitts" target="_self">Forum Post: Asshat rumor regarding Evan Engram and Kyle Pitts</a></li>
<li class="wp-cpl wp-cpl-odd"><a href="https://corner.bigblueinteractive.com/index.php?mode=2&amp;thread=608136&amp;show_all=1#new_tab" title="Permalink to: Forum Post: Let&#39;s agree on a definition for " qb="" hell""="" target="_self">Forum Post: Let&#39;s agree on a definition for &#34;QB Hell&#34;</a></li>
<li class="wp-cpl wp-cpl-even"><a href="https://corner.bigblueinteractive.com/index.php?mode=2&amp;thread=608142&amp;show_all=1#new_tab" title="Permalink to: Forum Post: Giants exploring trading down from 11 per Rap" target="_self">Forum Post: Giants exploring trading down from 11 per Rap</a></li>
<li class="wp-cpl wp-cpl-odd"><a href="https://corner.bigblueinteractive.com/index.php?mode=2&amp;thread=608126&amp;show_all=1#new_tab" title="Permalink to: Forum Post: okay, less than 2 weeks now: State your pick at #11" target="_self">Forum Post: okay, less than 2 weeks now: State your pick at #11</a></li>
</ul><p class="wp-cpl-teaser">The Hottest Discussions in BBI&#39;s Corner Forum</p></div></aside><!--widget end --><!--widget start --><aside id="text-533808690" class="dbx-box suf-widget widget_text"><div class="dbx-content">			<div class="textwidget"><b><a href="http://www.bigblueinteractive.com/category/news-and-notes/"> Do you miss the old Front Page Layout? <br/> Click here to see it!</a></b></div>
		</div></aside><!--widget end --><!--widget start --><aside id="categories-2" class="dbx-box suf-widget widget_categories"><div class="dbx-content"><h3 class="dbx-handle plain">Content Sections</h3><form action="http://www.bigblueinteractive.com" method="get"><label class="screen-reader-text" for="cat">Content Sections</label><select name="cat" id="cat" class="postform">
	<option value="-1">Select Category</option>
	<option class="level-0" value="8">Articles  (1,149)</option>
	<option class="level-0" value="34">Corner Forum Highlights  (52)</option>
	<option class="level-0" value="390">Features  (117)</option>
	<option class="level-0" value="64">Game Previews and Reviews  (1,020)</option>
	<option class="level-0" value="60">Giant Thoughts  (43)</option>
	<option class="level-0" value="39">Media  (64)</option>
	<option class="level-0" value="40">New York Giants History  (23)</option>
	<option class="level-0" value="3">News and Notes  (3,684)</option>
	<option class="level-0" value="9">Roster Breakdown  (164)</option>
	<option class="level-0" value="82">The Draft  (240)</option>
	<option class="level-0" value="7">The Salary Cap  (17)</option>
	<option class="level-0" value="65">Training Camp  (344)</option>
	<option class="level-0" value="106">Website Business  (8)</option>
</select>
</form>
<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "cat" );
	function onCatChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value > 0 ) {
			dropdown.parentNode.submit();
		}
	}
	dropdown.onchange = onCatChange;
})();
/* ]]> */
</script>

			</div></aside><!--widget end --><!--widget start --><aside id="search-3" class="dbx-box suf-widget search"><div class="dbx-content">
<form method="get" class="searchform " action="http://www.bigblueinteractive.com/">
	<input type="text" name="s" class="searchfield" value="Search" onfocus="if (this.value == &#39;Search&#39;) {this.value = &#39;&#39;;}" onblur="if (this.value == &#39;&#39;) {this.value = &#39;Search&#39;;}"/>
	<input type="submit" class="searchsubmit" value="" name="searchsubmit"/>
</form>
</div></aside><!--widget end -->		</div>
		<!-- /#wsidebar-top -->
<div id="sidebar-shell-1" class="sidebar-shell sidebar-shell-right">
<div class="dbx-group right flattened warea" id="sidebar">
<!--widget start --><aside id="media_image-2" class="suf-flat-widget widget_media_image"><a href="http://web.yesnetwork.com/"><img width="246" height="127" src="http://www.bigblueinteractive.com/wp-content/uploads/YES-Logo-November-2020-cropped.png" class="image wp-image-101239  attachment-full size-full" alt="Yes Network Logo" style="max-width: 100%; height: auto;" srcset="http://www.bigblueinteractive.com/wp-content/uploads/YES-Logo-November-2020-cropped.png 246w, http://www.bigblueinteractive.com/wp-content/uploads/YES-Logo-November-2020-cropped-150x77.png 150w" sizes="(max-width: 246px) 100vw, 246px"/></a></aside><!--widget end --></div><!--/sidebar -->
</div>
<div id="sidebar-shell-2" class="sidebar-shell sidebar-shell-right">
<div class="dbx-group right boxed warea" id="sidebar-2">

  
</div><!--/sidebar-2 -->
</div>
		<!-- #wsidebar-bottom -->
		<div id="wsidebar-bottom" class="dbx-group right boxed warea">
<!--widget start --><aside id="archives-2" class="dbx-box suf-widget widget_archive"><div class="dbx-content"><h3 class="dbx-handle plain">Posts By Month</h3>		<label class="screen-reader-text" for="archives-dropdown-2">Posts By Month</label>
		<select id="archives-dropdown-2" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value="http://www.bigblueinteractive.com/2021/04/"> April 2021  (49)</option>
	<option value="http://www.bigblueinteractive.com/2021/03/"> March 2021  (40)</option>
	<option value="http://www.bigblueinteractive.com/2021/02/"> February 2021  (8)</option>
	<option value="http://www.bigblueinteractive.com/2021/01/"> January 2021  (18)</option>
	<option value="http://www.bigblueinteractive.com/2020/12/"> December 2020  (34)</option>
	<option value="http://www.bigblueinteractive.com/2020/11/"> November 2020  (28)</option>
	<option value="http://www.bigblueinteractive.com/2020/10/"> October 2020  (31)</option>
	<option value="http://www.bigblueinteractive.com/2020/09/"> September 2020  (32)</option>
	<option value="http://www.bigblueinteractive.com/2020/08/"> August 2020  (28)</option>
	<option value="http://www.bigblueinteractive.com/2020/07/"> July 2020  (12)</option>
	<option value="http://www.bigblueinteractive.com/2020/06/"> June 2020  (7)</option>
	<option value="http://www.bigblueinteractive.com/2020/05/"> May 2020  (14)</option>
	<option value="http://www.bigblueinteractive.com/2020/04/"> April 2020  (28)</option>
	<option value="http://www.bigblueinteractive.com/2020/03/"> March 2020  (22)</option>
	<option value="http://www.bigblueinteractive.com/2020/02/"> February 2020  (4)</option>
	<option value="http://www.bigblueinteractive.com/2020/01/"> January 2020  (17)</option>
	<option value="http://www.bigblueinteractive.com/2019/12/"> December 2019  (34)</option>
	<option value="http://www.bigblueinteractive.com/2019/11/"> November 2019  (26)</option>
	<option value="http://www.bigblueinteractive.com/2019/10/"> October 2019  (31)</option>
	<option value="http://www.bigblueinteractive.com/2019/09/"> September 2019  (31)</option>
	<option value="http://www.bigblueinteractive.com/2019/08/"> August 2019  (32)</option>
	<option value="http://www.bigblueinteractive.com/2019/07/"> July 2019  (14)</option>
	<option value="http://www.bigblueinteractive.com/2019/06/"> June 2019  (14)</option>
	<option value="http://www.bigblueinteractive.com/2019/05/"> May 2019  (15)</option>
	<option value="http://www.bigblueinteractive.com/2019/04/"> April 2019  (22)</option>
	<option value="http://www.bigblueinteractive.com/2019/03/"> March 2019  (15)</option>
	<option value="http://www.bigblueinteractive.com/2019/02/"> February 2019  (14)</option>
	<option value="http://www.bigblueinteractive.com/2019/01/"> January 2019  (7)</option>
	<option value="http://www.bigblueinteractive.com/2018/12/"> December 2018  (33)</option>
	<option value="http://www.bigblueinteractive.com/2018/11/"> November 2018  (26)</option>
	<option value="http://www.bigblueinteractive.com/2018/10/"> October 2018  (31)</option>
	<option value="http://www.bigblueinteractive.com/2018/09/"> September 2018  (31)</option>
	<option value="http://www.bigblueinteractive.com/2018/08/"> August 2018  (33)</option>
	<option value="http://www.bigblueinteractive.com/2018/07/"> July 2018  (16)</option>
	<option value="http://www.bigblueinteractive.com/2018/06/"> June 2018  (13)</option>
	<option value="http://www.bigblueinteractive.com/2018/05/"> May 2018  (13)</option>
	<option value="http://www.bigblueinteractive.com/2018/04/"> April 2018  (32)</option>
	<option value="http://www.bigblueinteractive.com/2018/03/"> March 2018  (25)</option>
	<option value="http://www.bigblueinteractive.com/2018/02/"> February 2018  (7)</option>
	<option value="http://www.bigblueinteractive.com/2018/01/"> January 2018  (21)</option>
	<option value="http://www.bigblueinteractive.com/2017/12/"> December 2017  (36)</option>
	<option value="http://www.bigblueinteractive.com/2017/11/"> November 2017  (33)</option>
	<option value="http://www.bigblueinteractive.com/2017/10/"> October 2017  (32)</option>
	<option value="http://www.bigblueinteractive.com/2017/09/"> September 2017  (33)</option>
	<option value="http://www.bigblueinteractive.com/2017/08/"> August 2017  (33)</option>
	<option value="http://www.bigblueinteractive.com/2017/07/"> July 2017  (19)</option>
	<option value="http://www.bigblueinteractive.com/2017/06/"> June 2017  (9)</option>
	<option value="http://www.bigblueinteractive.com/2017/05/"> May 2017  (14)</option>
	<option value="http://www.bigblueinteractive.com/2017/04/"> April 2017  (34)</option>
	<option value="http://www.bigblueinteractive.com/2017/03/"> March 2017  (32)</option>
	<option value="http://www.bigblueinteractive.com/2017/02/"> February 2017  (18)</option>
	<option value="http://www.bigblueinteractive.com/2017/01/"> January 2017  (19)</option>
	<option value="http://www.bigblueinteractive.com/2016/12/"> December 2016  (43)</option>
	<option value="http://www.bigblueinteractive.com/2016/11/"> November 2016  (34)</option>
	<option value="http://www.bigblueinteractive.com/2016/10/"> October 2016  (31)</option>
	<option value="http://www.bigblueinteractive.com/2016/09/"> September 2016  (33)</option>
	<option value="http://www.bigblueinteractive.com/2016/08/"> August 2016  (33)</option>
	<option value="http://www.bigblueinteractive.com/2016/07/"> July 2016  (10)</option>
	<option value="http://www.bigblueinteractive.com/2016/06/"> June 2016  (10)</option>
	<option value="http://www.bigblueinteractive.com/2016/05/"> May 2016  (16)</option>
	<option value="http://www.bigblueinteractive.com/2016/04/"> April 2016  (32)</option>
	<option value="http://www.bigblueinteractive.com/2016/03/"> March 2016  (35)</option>
	<option value="http://www.bigblueinteractive.com/2016/02/"> February 2016  (22)</option>
	<option value="http://www.bigblueinteractive.com/2016/01/"> January 2016  (43)</option>
	<option value="http://www.bigblueinteractive.com/2015/12/"> December 2015  (45)</option>
	<option value="http://www.bigblueinteractive.com/2015/11/"> November 2015  (32)</option>
	<option value="http://www.bigblueinteractive.com/2015/10/"> October 2015  (41)</option>
	<option value="http://www.bigblueinteractive.com/2015/09/"> September 2015  (40)</option>
	<option value="http://www.bigblueinteractive.com/2015/08/"> August 2015  (36)</option>
	<option value="http://www.bigblueinteractive.com/2015/07/"> July 2015  (35)</option>
	<option value="http://www.bigblueinteractive.com/2015/06/"> June 2015  (25)</option>
	<option value="http://www.bigblueinteractive.com/2015/05/"> May 2015  (29)</option>
	<option value="http://www.bigblueinteractive.com/2015/04/"> April 2015  (31)</option>
	<option value="http://www.bigblueinteractive.com/2015/03/"> March 2015  (49)</option>
	<option value="http://www.bigblueinteractive.com/2015/02/"> February 2015  (24)</option>
	<option value="http://www.bigblueinteractive.com/2015/01/"> January 2015  (32)</option>
	<option value="http://www.bigblueinteractive.com/2014/12/"> December 2014  (47)</option>
	<option value="http://www.bigblueinteractive.com/2014/11/"> November 2014  (37)</option>
	<option value="http://www.bigblueinteractive.com/2014/10/"> October 2014  (37)</option>
	<option value="http://www.bigblueinteractive.com/2014/09/"> September 2014  (49)</option>
	<option value="http://www.bigblueinteractive.com/2014/08/"> August 2014  (84)</option>
	<option value="http://www.bigblueinteractive.com/2014/07/"> July 2014  (89)</option>
	<option value="http://www.bigblueinteractive.com/2014/06/"> June 2014  (46)</option>
	<option value="http://www.bigblueinteractive.com/2014/05/"> May 2014  (47)</option>
	<option value="http://www.bigblueinteractive.com/2014/04/"> April 2014  (41)</option>
	<option value="http://www.bigblueinteractive.com/2014/03/"> March 2014  (46)</option>
	<option value="http://www.bigblueinteractive.com/2014/02/"> February 2014  (17)</option>
	<option value="http://www.bigblueinteractive.com/2014/01/"> January 2014  (36)</option>
	<option value="http://www.bigblueinteractive.com/2013/12/"> December 2013  (51)</option>
	<option value="http://www.bigblueinteractive.com/2013/11/"> November 2013  (38)</option>
	<option value="http://www.bigblueinteractive.com/2013/10/"> October 2013  (41)</option>
	<option value="http://www.bigblueinteractive.com/2013/09/"> September 2013  (40)</option>
	<option value="http://www.bigblueinteractive.com/2013/08/"> August 2013  (48)</option>
	<option value="http://www.bigblueinteractive.com/2013/07/"> July 2013  (35)</option>
	<option value="http://www.bigblueinteractive.com/2013/06/"> June 2013  (25)</option>
	<option value="http://www.bigblueinteractive.com/2013/05/"> May 2013  (28)</option>
	<option value="http://www.bigblueinteractive.com/2013/04/"> April 2013  (34)</option>
	<option value="http://www.bigblueinteractive.com/2013/03/"> March 2013  (24)</option>
	<option value="http://www.bigblueinteractive.com/2013/02/"> February 2013  (16)</option>
	<option value="http://www.bigblueinteractive.com/2013/01/"> January 2013  (15)</option>
	<option value="http://www.bigblueinteractive.com/2012/12/"> December 2012  (36)</option>
	<option value="http://www.bigblueinteractive.com/2012/11/"> November 2012  (33)</option>
	<option value="http://www.bigblueinteractive.com/2012/10/"> October 2012  (37)</option>
	<option value="http://www.bigblueinteractive.com/2012/09/"> September 2012  (35)</option>
	<option value="http://www.bigblueinteractive.com/2012/08/"> August 2012  (56)</option>
	<option value="http://www.bigblueinteractive.com/2012/07/"> July 2012  (28)</option>
	<option value="http://www.bigblueinteractive.com/2012/06/"> June 2012  (20)</option>
	<option value="http://www.bigblueinteractive.com/2012/05/"> May 2012  (21)</option>
	<option value="http://www.bigblueinteractive.com/2012/04/"> April 2012  (18)</option>
	<option value="http://www.bigblueinteractive.com/2012/03/"> March 2012  (22)</option>
	<option value="http://www.bigblueinteractive.com/2012/02/"> February 2012  (20)</option>
	<option value="http://www.bigblueinteractive.com/2012/01/"> January 2012  (39)</option>
	<option value="http://www.bigblueinteractive.com/2011/12/"> December 2011  (39)</option>
	<option value="http://www.bigblueinteractive.com/2011/11/"> November 2011  (35)</option>
	<option value="http://www.bigblueinteractive.com/2011/10/"> October 2011  (34)</option>
	<option value="http://www.bigblueinteractive.com/2011/09/"> September 2011  (36)</option>
	<option value="http://www.bigblueinteractive.com/2011/08/"> August 2011  (41)</option>
	<option value="http://www.bigblueinteractive.com/2011/07/"> July 2011  (18)</option>
	<option value="http://www.bigblueinteractive.com/2011/06/"> June 2011  (15)</option>
	<option value="http://www.bigblueinteractive.com/2011/05/"> May 2011  (10)</option>
	<option value="http://www.bigblueinteractive.com/2011/04/"> April 2011  (9)</option>
	<option value="http://www.bigblueinteractive.com/2011/03/"> March 2011  (9)</option>
	<option value="http://www.bigblueinteractive.com/2011/02/"> February 2011  (11)</option>
	<option value="http://www.bigblueinteractive.com/2011/01/"> January 2011  (14)</option>
	<option value="http://www.bigblueinteractive.com/2010/12/"> December 2010  (41)</option>
	<option value="http://www.bigblueinteractive.com/2010/11/"> November 2010  (38)</option>
	<option value="http://www.bigblueinteractive.com/2010/10/"> October 2010  (37)</option>
	<option value="http://www.bigblueinteractive.com/2010/09/"> September 2010  (41)</option>
	<option value="http://www.bigblueinteractive.com/2010/08/"> August 2010  (52)</option>
	<option value="http://www.bigblueinteractive.com/2010/07/"> July 2010  (13)</option>
	<option value="http://www.bigblueinteractive.com/2010/06/"> June 2010  (14)</option>
	<option value="http://www.bigblueinteractive.com/2010/05/"> May 2010  (15)</option>
	<option value="http://www.bigblueinteractive.com/2010/04/"> April 2010  (22)</option>
	<option value="http://www.bigblueinteractive.com/2010/03/"> March 2010  (17)</option>
	<option value="http://www.bigblueinteractive.com/2010/02/"> February 2010  (15)</option>
	<option value="http://www.bigblueinteractive.com/2010/01/"> January 2010  (20)</option>
	<option value="http://www.bigblueinteractive.com/2009/12/"> December 2009  (44)</option>
	<option value="http://www.bigblueinteractive.com/2009/11/"> November 2009  (29)</option>
	<option value="http://www.bigblueinteractive.com/2009/10/"> October 2009  (42)</option>
	<option value="http://www.bigblueinteractive.com/2009/09/"> September 2009  (41)</option>
	<option value="http://www.bigblueinteractive.com/2009/08/"> August 2009  (55)</option>
	<option value="http://www.bigblueinteractive.com/2009/07/"> July 2009  (11)</option>
	<option value="http://www.bigblueinteractive.com/2009/06/"> June 2009  (13)</option>
	<option value="http://www.bigblueinteractive.com/2009/05/"> May 2009  (10)</option>
	<option value="http://www.bigblueinteractive.com/2009/04/"> April 2009  (17)</option>
	<option value="http://www.bigblueinteractive.com/2009/03/"> March 2009  (14)</option>
	<option value="http://www.bigblueinteractive.com/2009/02/"> February 2009  (17)</option>
	<option value="http://www.bigblueinteractive.com/2009/01/"> January 2009  (27)</option>
	<option value="http://www.bigblueinteractive.com/2008/12/"> December 2008  (40)</option>
	<option value="http://www.bigblueinteractive.com/2008/11/"> November 2008  (36)</option>
	<option value="http://www.bigblueinteractive.com/2008/10/"> October 2008  (36)</option>
	<option value="http://www.bigblueinteractive.com/2008/09/"> September 2008  (27)</option>
	<option value="http://www.bigblueinteractive.com/2008/08/"> August 2008  (48)</option>
	<option value="http://www.bigblueinteractive.com/2008/07/"> July 2008  (26)</option>
	<option value="http://www.bigblueinteractive.com/2008/06/"> June 2008  (19)</option>
	<option value="http://www.bigblueinteractive.com/2008/05/"> May 2008  (19)</option>
	<option value="http://www.bigblueinteractive.com/2008/04/"> April 2008  (25)</option>
	<option value="http://www.bigblueinteractive.com/2008/03/"> March 2008  (19)</option>
	<option value="http://www.bigblueinteractive.com/2008/02/"> February 2008  (28)</option>
	<option value="http://www.bigblueinteractive.com/2008/01/"> January 2008  (39)</option>
	<option value="http://www.bigblueinteractive.com/2007/12/"> December 2007  (40)</option>
	<option value="http://www.bigblueinteractive.com/2007/11/"> November 2007  (35)</option>
	<option value="http://www.bigblueinteractive.com/2007/10/"> October 2007  (37)</option>
	<option value="http://www.bigblueinteractive.com/2007/09/"> September 2007  (35)</option>
	<option value="http://www.bigblueinteractive.com/2007/08/"> August 2007  (59)</option>
	<option value="http://www.bigblueinteractive.com/2007/07/"> July 2007  (19)</option>
	<option value="http://www.bigblueinteractive.com/2007/06/"> June 2007  (10)</option>
	<option value="http://www.bigblueinteractive.com/2007/05/"> May 2007  (21)</option>
	<option value="http://www.bigblueinteractive.com/2007/04/"> April 2007  (22)</option>
	<option value="http://www.bigblueinteractive.com/2007/03/"> March 2007  (28)</option>
	<option value="http://www.bigblueinteractive.com/2007/02/"> February 2007  (20)</option>
	<option value="http://www.bigblueinteractive.com/2007/01/"> January 2007  (28)</option>
	<option value="http://www.bigblueinteractive.com/2006/12/"> December 2006  (35)</option>
	<option value="http://www.bigblueinteractive.com/2006/11/"> November 2006  (35)</option>
	<option value="http://www.bigblueinteractive.com/2006/10/"> October 2006  (30)</option>
	<option value="http://www.bigblueinteractive.com/2006/09/"> September 2006  (29)</option>
	<option value="http://www.bigblueinteractive.com/2006/08/"> August 2006  (60)</option>
	<option value="http://www.bigblueinteractive.com/2006/07/"> July 2006  (22)</option>
	<option value="http://www.bigblueinteractive.com/2006/06/"> June 2006  (16)</option>
	<option value="http://www.bigblueinteractive.com/2006/05/"> May 2006  (18)</option>
	<option value="http://www.bigblueinteractive.com/2006/04/"> April 2006  (4)</option>
	<option value="http://www.bigblueinteractive.com/2006/02/"> February 2006  (2)</option>
	<option value="http://www.bigblueinteractive.com/2006/01/"> January 2006  (3)</option>
	<option value="http://www.bigblueinteractive.com/2005/12/"> December 2005  (9)</option>
	<option value="http://www.bigblueinteractive.com/2005/11/"> November 2005  (10)</option>
	<option value="http://www.bigblueinteractive.com/2005/10/"> October 2005  (7)</option>
	<option value="http://www.bigblueinteractive.com/2005/09/"> September 2005  (8)</option>
	<option value="http://www.bigblueinteractive.com/2005/08/"> August 2005  (18)</option>
	<option value="http://www.bigblueinteractive.com/2005/07/"> July 2005  (9)</option>
	<option value="http://www.bigblueinteractive.com/2005/04/"> April 2005  (2)</option>
	<option value="http://www.bigblueinteractive.com/2005/02/"> February 2005  (1)</option>
	<option value="http://www.bigblueinteractive.com/2005/01/"> January 2005  (1)</option>
	<option value="http://www.bigblueinteractive.com/2004/12/"> December 2004  (11)</option>
	<option value="http://www.bigblueinteractive.com/2004/11/"> November 2004  (8)</option>
	<option value="http://www.bigblueinteractive.com/2004/10/"> October 2004  (7)</option>
	<option value="http://www.bigblueinteractive.com/2004/09/"> September 2004  (11)</option>
	<option value="http://www.bigblueinteractive.com/2004/08/"> August 2004  (10)</option>
	<option value="http://www.bigblueinteractive.com/2004/07/"> July 2004  (1)</option>
	<option value="http://www.bigblueinteractive.com/2004/06/"> June 2004  (1)</option>
	<option value="http://www.bigblueinteractive.com/2004/04/"> April 2004  (3)</option>
	<option value="http://www.bigblueinteractive.com/2004/03/"> March 2004  (2)</option>
	<option value="http://www.bigblueinteractive.com/2004/02/"> February 2004  (2)</option>
	<option value="http://www.bigblueinteractive.com/2004/01/"> January 2004  (1)</option>
	<option value="http://www.bigblueinteractive.com/2003/12/"> December 2003  (10)</option>
	<option value="http://www.bigblueinteractive.com/2003/11/"> November 2003  (8)</option>
	<option value="http://www.bigblueinteractive.com/2003/10/"> October 2003  (9)</option>
	<option value="http://www.bigblueinteractive.com/2003/09/"> September 2003  (7)</option>
	<option value="http://www.bigblueinteractive.com/2003/08/"> August 2003  (19)</option>
	<option value="http://www.bigblueinteractive.com/2003/07/"> July 2003  (2)</option>
	<option value="http://www.bigblueinteractive.com/2003/06/"> June 2003  (2)</option>
	<option value="http://www.bigblueinteractive.com/2003/05/"> May 2003  (1)</option>
	<option value="http://www.bigblueinteractive.com/2003/04/"> April 2003  (4)</option>
	<option value="http://www.bigblueinteractive.com/2003/02/"> February 2003  (1)</option>
	<option value="http://www.bigblueinteractive.com/2003/01/"> January 2003  (3)</option>
	<option value="http://www.bigblueinteractive.com/2002/12/"> December 2002  (9)</option>
	<option value="http://www.bigblueinteractive.com/2002/11/"> November 2002  (9)</option>
	<option value="http://www.bigblueinteractive.com/2002/10/"> October 2002  (10)</option>
	<option value="http://www.bigblueinteractive.com/2002/09/"> September 2002  (9)</option>
	<option value="http://www.bigblueinteractive.com/2002/08/"> August 2002  (21)</option>
	<option value="http://www.bigblueinteractive.com/2002/07/"> July 2002  (4)</option>
	<option value="http://www.bigblueinteractive.com/2002/05/"> May 2002  (4)</option>
	<option value="http://www.bigblueinteractive.com/2002/04/"> April 2002  (3)</option>
	<option value="http://www.bigblueinteractive.com/2002/03/"> March 2002  (1)</option>
	<option value="http://www.bigblueinteractive.com/2002/02/"> February 2002  (1)</option>
	<option value="http://www.bigblueinteractive.com/2002/01/"> January 2002  (3)</option>
	<option value="http://www.bigblueinteractive.com/2001/12/"> December 2001  (8)</option>
	<option value="http://www.bigblueinteractive.com/2001/11/"> November 2001  (8)</option>
	<option value="http://www.bigblueinteractive.com/2001/10/"> October 2001  (11)</option>
	<option value="http://www.bigblueinteractive.com/2001/09/"> September 2001  (7)</option>
	<option value="http://www.bigblueinteractive.com/2001/08/"> August 2001  (13)</option>
	<option value="http://www.bigblueinteractive.com/2001/07/"> July 2001  (3)</option>
	<option value="http://www.bigblueinteractive.com/2001/05/"> May 2001  (1)</option>
	<option value="http://www.bigblueinteractive.com/2001/04/"> April 2001  (2)</option>
	<option value="http://www.bigblueinteractive.com/2001/02/"> February 2001  (2)</option>
	<option value="http://www.bigblueinteractive.com/2001/01/"> January 2001  (6)</option>
	<option value="http://www.bigblueinteractive.com/2000/12/"> December 2000  (8)</option>
	<option value="http://www.bigblueinteractive.com/2000/11/"> November 2000  (9)</option>
	<option value="http://www.bigblueinteractive.com/2000/10/"> October 2000  (6)</option>
	<option value="http://www.bigblueinteractive.com/2000/09/"> September 2000  (9)</option>
	<option value="http://www.bigblueinteractive.com/2000/08/"> August 2000  (9)</option>
	<option value="http://www.bigblueinteractive.com/2000/07/"> July 2000  (2)</option>
	<option value="http://www.bigblueinteractive.com/2000/06/"> June 2000  (1)</option>
	<option value="http://www.bigblueinteractive.com/2000/04/"> April 2000  (5)</option>
	<option value="http://www.bigblueinteractive.com/2000/02/"> February 2000  (1)</option>
	<option value="http://www.bigblueinteractive.com/2000/01/"> January 2000  (2)</option>
	<option value="http://www.bigblueinteractive.com/1999/12/"> December 1999  (10)</option>
	<option value="http://www.bigblueinteractive.com/1999/11/"> November 1999  (6)</option>
	<option value="http://www.bigblueinteractive.com/1999/10/"> October 1999  (9)</option>
	<option value="http://www.bigblueinteractive.com/1999/09/"> September 1999  (8)</option>
	<option value="http://www.bigblueinteractive.com/1999/08/"> August 1999  (6)</option>
	<option value="http://www.bigblueinteractive.com/1999/07/"> July 1999  (2)</option>
	<option value="http://www.bigblueinteractive.com/1999/04/"> April 1999  (2)</option>
	<option value="http://www.bigblueinteractive.com/1999/03/"> March 1999  (1)</option>
	<option value="http://www.bigblueinteractive.com/1999/02/"> February 1999  (1)</option>
	<option value="http://www.bigblueinteractive.com/1998/12/"> December 1998  (9)</option>
	<option value="http://www.bigblueinteractive.com/1998/11/"> November 1998  (8)</option>
	<option value="http://www.bigblueinteractive.com/1998/10/"> October 1998  (7)</option>
	<option value="http://www.bigblueinteractive.com/1998/09/"> September 1998  (8)</option>
	<option value="http://www.bigblueinteractive.com/1998/08/"> August 1998  (8)</option>
	<option value="http://www.bigblueinteractive.com/1998/07/"> July 1998  (2)</option>
	<option value="http://www.bigblueinteractive.com/1998/04/"> April 1998  (2)</option>
	<option value="http://www.bigblueinteractive.com/1998/03/"> March 1998  (1)</option>
	<option value="http://www.bigblueinteractive.com/1998/02/"> February 1998  (1)</option>
	<option value="http://www.bigblueinteractive.com/1997/12/"> December 1997  (9)</option>
	<option value="http://www.bigblueinteractive.com/1997/11/"> November 1997  (8)</option>
	<option value="http://www.bigblueinteractive.com/1997/10/"> October 1997  (10)</option>
	<option value="http://www.bigblueinteractive.com/1997/09/"> September 1997  (8)</option>
	<option value="http://www.bigblueinteractive.com/1997/08/"> August 1997  (8)</option>
	<option value="http://www.bigblueinteractive.com/1997/07/"> July 1997  (3)</option>
	<option value="http://www.bigblueinteractive.com/1997/06/"> June 1997  (1)</option>
	<option value="http://www.bigblueinteractive.com/1997/04/"> April 1997  (1)</option>
	<option value="http://www.bigblueinteractive.com/1997/03/"> March 1997  (1)</option>
	<option value="http://www.bigblueinteractive.com/1996/12/"> December 1996  (7)</option>
	<option value="http://www.bigblueinteractive.com/1996/11/"> November 1996  (9)</option>
	<option value="http://www.bigblueinteractive.com/1996/10/"> October 1996  (6)</option>
	<option value="http://www.bigblueinteractive.com/1996/09/"> September 1996  (5)</option>
	<option value="http://www.bigblueinteractive.com/1996/08/"> August 1996  (5)</option>
	<option value="http://www.bigblueinteractive.com/1996/07/"> July 1996  (1)</option>
	<option value="http://www.bigblueinteractive.com/1996/05/"> May 1996  (1)</option>
	<option value="http://www.bigblueinteractive.com/1996/04/"> April 1996  (2)</option>
	<option value="http://www.bigblueinteractive.com/1995/07/"> July 1995  (1)</option>
	<option value="http://www.bigblueinteractive.com/1995/05/"> May 1995  (1)</option>
	<option value="http://www.bigblueinteractive.com/2021/04/">  0  (1)</option>

		</select>

<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-2" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>

		</div></aside><!--widget end --><!--widget start --><aside id="text-533808692" class="dbx-box suf-widget widget_text"><div class="dbx-content">			<div class="textwidget"><!-- Ezoic - ROS Lower Box (AdSense) - sidebar_middle -->
<div id="ezoic-pub-ad-placeholder-103">
<script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- ROS - Lower 300x250 Box -->
<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-1566320450447229" data-ad-slot="8997951193"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<!-- End Ezoic - ROS Lower Box (AdSense) - sidebar_middle --></div>
		</div></aside><!--widget end --><!--widget start --><aside id="text-533808694" class="dbx-box suf-widget widget_text"><div class="dbx-content">			<div class="textwidget"></div>
		</div></aside><!--widget end --><!--widget start --><aside id="custom_html-4" class="widget_text dbx-box suf-widget widget_custom_html"><div class="widget_text dbx-content"><div class="textwidget custom-html-widget"><div style="text-align:center;">
<a href="http://pcqb.com" rel="nofollow"><img src="/images/pcqb-we-fix-broken-sites.png" title="Site managed by PCQB WordPress Support" alt="We Fix Broken Websites"/></a>
</div></div></div></aside><!--widget end -->		</div>
		<!-- /#wsidebar-bottom -->
</div>	</div><!-- /container -->

<footer>
	<div id="cred">
		<table>
			<tbody><tr>
				<td class="cred-left">	<p><b>Part of the USA Today Sports Media Group</b><br/>
BigBlueInteractive<sup>SM</sup> provides news, analysis, and discussion on the New York Football Giants. The site is owned and operated by Big Blue Interactive, LLC.  If you
have any questions or comments about this website, please see our <a href="http://www.bigblueinteractive.com/information-pages/contact-us/">contact information page</a>.

</p>
</td>
				<td class="cred-center"> </td>
				<td class="cred-right"><p>
All contents (unless otherwise specified) copyright ©  1995 - 2020
Big Blue Interactive, LLC. All Rights Reserved.<br/>Site Managed by<br/> <a href="http://www.pcqb.com/" target="new" rel-"nofollow"="">PCQB WordPress Support</a>
</p>
</td>
			</tr>
		</tbody></table>
	</div>
</footer>
<!-- 74 queries, 33MB in 0.704 seconds. -->
</div><!--/wrapper -->
<!-- location footer -->
<!-- SMG_BigBlueInteractive/skin/sports/football/nfl.main -->
<div id="usmg_ad_SMG_BigBlueInteractive_skin_sports_football_nfl.main">
     <script type="text/javascript">
         googletag.cmd.push(function() {
             googletag.defineSlot('/7103/SMG_BigBlueInteractive/skin/sports/football/nfl.main', [1,1], 'usmg_ad_SMG_BigBlueInteractive_skin_sports_football_nfl.main').addService(googletag.pubads());
             googletag.enableServices();
             googletag.display('usmg_ad_SMG_BigBlueInteractive_skin_sports_football_nfl.main');
         });
     </script>
</div>

      <script type="text/javascript">

          var pfHeaderImgUrl = '';
          var pfHeaderTagline = '';
          var pfdisableClickToDel = '0';
          var pfImagesSize = 'full-size';
          var pfImageDisplayStyle = 'right';
          var pfEncodeImages = '0';
          var pfDisableEmail = '0';
          var pfDisablePDF = '0';
          var pfDisablePrint = '0';
          var pfCustomCSS = '';
          var pfPlatform = 'Wordpress';
      </script>
      <script async="" src="https://cdn.printfriendly.com/printfriendly.js"></script>
<script type="text/javascript" src="http://www.bigblueinteractive.com/wp-includes/js/comment-reply.min.js?ver=5.2.4"></script>
<script type="text/javascript">
/* <![CDATA[ */
var qpprFrontData = {"linkData":[],"siteURL":"http:\/\/www.bigblueinteractive.com","siteURLq":"http:\/\/www.bigblueinteractive.com"};
/* ]]> */
</script>
<script type="text/javascript" src="http://www.bigblueinteractive.com/wp-content/plugins/quick-pagepost-redirect-plugin/js/qppr_frontend_script.min.js?ver=5.2.0"></script>
<script type="text/javascript" src="http://www.bigblueinteractive.com/wp-content/plugins/page-links-to/js/new-tab.min.js?ver=3.1.2"></script>
<script type="text/javascript" src="http://www.bigblueinteractive.com/wp-includes/js/wp-embed.min.js?ver=5.2.4"></script>



<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="bigblueinteractive_com",_audins_did=124135;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=194-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.bigblueinteractive_com,DomainId.124135" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=0&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script></body></html>